Ask Your Question
0

Issues with catkin_ws/src

asked 2017-03-20 21:36:52 -0500

Dynamite gravatar image

updated 2017-03-21 00:05:51 -0500

I don't know what is wrong, but everytime I follow a tutorial and have to use the catkin workspace src folder or similar then I get an issue.

I'm in doubt can this issue be solved? what can I do to fix it? Or do I have to reinstall ROS?

Just an example but this is everytime I try with anything:

kevin@kevin-Lenovo:~$ cd dev/catkin_ws/src/
bash: cd: dev/catkin_ws/src/: No such file or directory

is the issue the location? /home/kevin/ros/catkin_ws

I use ROS Indigo and Ubuntu 14.04 trusty

I'll be so grateful if someone can help me solve this. I would love to learn ROS. Thanks have a great day to all.

btw I'm trying to run ROS with arduino through ros-serial:

$ sudo apt-get install ros-indigo-rosserial-arduino
$ sudo apt-get install ros-indigo-rosserial

$ cd dev/catkin_ws/src/
$ git clone https://github.com/ros-drivers/rosserial.git
$ cd dev/catkin_ws/
$ catkin_make
$ catkin_make install
$ source install/setup.bash
edit retag flag offensive close merge delete

Comments

Maybe you did not overlay the workspace to the working environment(ROS). Have you done that?

sam26 gravatar image sam26  ( 2017-03-20 21:47:15 -0500 )edit

hey thanks After reading your comment I went through this tutorial: http://wiki.ros.org/catkin/Tutorials/... - worked out great - no issues. then I tried again - same result:

kevin@kevin-Lenovo:~$ cd dev/catkin_ws/ bash: cd: dev/catkin_ws/: No such file or directory What can it be?

Dynamite gravatar image Dynamite  ( 2017-03-20 22:42:04 -0500 )edit

btw I'm pretty knew to this only doing basic tutorials and the turtle sim, gazebo so far and two month of ubuntu use. I'm unfortunately kinda clueless now.

Dynamite gravatar image Dynamite  ( 2017-03-20 22:43:46 -0500 )edit

what do you mean by then I tried again - same result: ? what are you exactly doing that is giving out that error?

sam26 gravatar image sam26  ( 2017-03-20 23:13:03 -0500 )edit

Sorry trying to run ros-serial for ros and arduino. - I updated the original post for more info.

Dynamite gravatar image Dynamite  ( 2017-03-20 23:21:57 -0500 )edit

I am quite not sure but if it worked earlier and not working at a later point, the only problem I can think of is the environment setup after ros installation. Check the environment setup

sam26 gravatar image sam26  ( 2017-03-20 23:50:19 -0500 )edit

If you permanently add the sourcing of setup file to the bash script you don't manually have to do it everytime you open a new terminal.

sam26 gravatar image sam26  ( 2017-03-20 23:52:16 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-03-21 00:03:57 -0500

DinnerHowe gravatar image

why you type command like this cd dev/catkin_ws/ bash: cd: dev/catkin_ws/:?

normally, you should type command in terminal like this cd ~/workspace/src, because we usually put our workspace under /home/*** not under /dev/*** , the /dev index is used to store devices.

edit flag offensive delete link more

Comments

I agree, I do not understand why you would create the workspace in dev space. To me it looks like the workspace has not been created in the correct folders.

Bogdar_ gravatar image Bogdar_  ( 2017-03-22 04:31:01 -0500 )edit
0

answered 2017-03-22 20:53:43 -0500

Dynamite gravatar image

updated 2017-03-22 21:15:56 -0500

First of all. Thank you to everyone. Specially sam26. really nice of you to help and suggest multiply times. Thanks fellow roboteer.

I managed to get it working from everyones help. Now I've with success run a node in ros with rosserial and arduino to spin a motor and I've read coordinates from my spacemouse with spacenav_node tutorial.

I'm so happy. Thanks again. unfortunately this also means I'll now start asking more questions haha.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-03-20 21:36:52 -0500

Seen: 1,120 times

Last updated: Mar 22 '17