Ask Your Question
0

Fail to run bebopś ROS driver as a node

asked 2017-03-20 05:21:45 -0600

abm39 gravatar image

updated 2017-09-14 17:57:40 -0600

jayess gravatar image

Hi, I have installed ROS Kenetic and build the workspace successfully and then installed the bebop ROS autonomy following installation steps from official bebop ROS webpage: to use it with my bebop 1 of firmware 1.98.

But when I tried to run the ROS driver as steps listed in (bebop ROS installation) as a node or nodelet I get problems.

**Here is for example the Error I got when I tried to run it as a Node:

~/bebop_ws/src/bebop_autonomy/bebop_driver/launch $ roslaunch bebop_node.launch

... logging to /home/pi/.ros/log/90cd26b4-0d53-11e7-a150-37eec44f5503/roslaunch-raspberrypiDalia-9215.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Invalid <arg> tag: bebop_driver
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/home/pi/bebop_ws/build/catkin_tools_prebuild

ROS path [2]=/opt/ros/kinetic/share. 

Arg xml is <arg default="$(find bebop_driver)/config/defaults.yaml" name="config_file"/>
The traceback for the exception was written to the log file

** And here is the the Error I got when trying to run the driver as nodelet:

~/bebop_ws/src/bebop_autonomy/bebop_tools/launch $ roslaunch  bebop_nodelet_iv.launch

... logging to /home/pi/.ros/log/a649540c-0d55-11e7-a2f2-b827ebbf1510/roslaunch-raspberrypiDalia-9941.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/__init__.py", line 307, in main
    p.start()
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/parent.py", line 268, in start
    self._start_infrastructure()
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/parent.py", line 217, in _start_infrastructure
    self._load_config()
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/parent.py", line 132, in _load_config
    roslaunch_strs=self.roslaunch_strs, verbose=self.verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/config.py", line 451, in load_config_default
    loader.load(f, config, verbose=verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 746, in load
    self._load_launch(launch, ros_config, is_core=core, filename=filename, argv=argv, verbose=verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 718, in _load_launch
    self._recurse_load(ros_config, launch.childNodes, self.root_context, None, is_core, verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 682, in _recurse_load
    val = self._include_tag(tag, context, ros_config, default_machine, is_core, verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 95, in call
    return f(*args, **kwds)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 587, in _include_tag
    inc_filename = self.resolve_args(tag.attributes['file'].value, context)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 183, in resolve_args
    return substitution_args.resolve_args(args, context=context.resolve_dict, resolve_anon=self.resolve_anon)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/substitution_args.py", line 370, in resolve_args
    resolved = _resolve_args(resolved, context, resolve_anon, commands)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/substitution_args.py", line 383, in ...
(more)
edit retag flag offensive close merge delete

Comments

It says "Invalid <arg>" in your first attempt to run the launch file, have you looked into that?

jayess gravatar imagejayess ( 2017-03-26 00:06:33 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-09-14 15:18:41 -0600

Hello,

I hope it's not too late, when you open a new terminal you have to type: $ source ~/bebop_ws/devel/setup.bash Because the catkin workspace must be sourced before running the driver.

BR:

edit flag offensive delete link more

Comments

Thank you for your reply, yes it is too late however, maybe others can benefit. I was working on a project and needed a library to program and control my drone, I used another library later and it worked with me.

abm39 gravatar imageabm39 ( 2017-09-14 21:48:27 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-03-20 05:21:45 -0600

Seen: 714 times

Last updated: Sep 14 '17