ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

moveit build error- move_group_interface.h file not found

asked 2017-03-17 05:42:57 -0600

updated 2017-03-18 11:01:54 -0600

v4hn gravatar image

I am running ROS indigo,I had installed moveit from user binary.When i try to do a catkin_make I get the following error in moveit packages:-


fatal_error: moveit/move_group_interface/move_group_interface.h : No such file or directory
#include moveit/move_group_interface/move_group_interface.h
compilation terminated!

I have made no changes to the moveit package. move_group_interface.h seems to be included in every example code, I dont see how it can be missing.

As a result in the custom package that i have created I am using move_group instead of move_group_interface.

edit retag flag offensive close merge delete


Why does it provide same clone link for both indigo-devel and kinetic-devel branch?. Downloading as zip worked though.

noAimInLife gravatar image noAimInLife  ( 2017-10-24 06:02:34 -0600 )edit

Because you clone a git repository, not a branch. You have to checkout the correct branch yourself.

v4hn gravatar image v4hn  ( 2017-11-17 09:45:43 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-03-18 11:08:00 -0600

v4hn gravatar image

The moveit_tutorials repository has a separate branch indigo-devel that works on indigo. You tried to compile the kinetic-devel branch that incorporates changes for MoveIt 0.9.x which is released in ROS kinetic.

edit flag offensive delete link more

Question Tools



Asked: 2017-03-17 05:42:57 -0600

Seen: 1,665 times

Last updated: Mar 18 '17