Ask Your Question
0

Issues installing image_view in ROS kinetic

asked 2017-03-15 11:54:13 -0500

eab gravatar image

updated 2017-03-16 12:29:25 -0500

Hello.

I am having problems with image_view on ROS Kinetic.

I first noticed it when I tried running

rosrun image_view image_view image:=/camera/image_raw

and I got the error

[rospack] Error: package 'image_view' not found

I confirmed that rospack cannot find it by running

rospack find image_view

and I get the same error.

I tried installing the image_view package with:

sudo apt-get update
sudo apt-get install ros-kinetic-image-view

with the following output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-kinetic-image-view

My /etc/apt/sources.list.d/ros-latest.list file is correct based on the installation instructions. I tried the "set up your keys" step again as well, no change.

The strangest part is it is running just fine on one computer, but not on another. So I know image-view exists for kinetic.

EDIT: I'm running Ubuntu 16.04 on an Intel Joule 570x development board. It has an Intel Atom processor on board.

edit retag flag offensive close merge delete

Comments

1

What OS/platform/arch are you on?

You've stated that you've done everything correctly, but it's not working. Please share your sources otherwise we can't reproduce to try to help you. There's clearly something different between the computers so please share anything else that's different too.

tfoote gravatar image tfoote  ( 2017-03-15 14:44:58 -0500 )edit

Added additional info in original post edit.

eab gravatar image eab  ( 2017-03-16 12:30:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-05-22 00:01:20 -0500

zlg9 gravatar image

updated 2021-05-22 00:05:00 -0500

Build from source (assuming your workspace is located in ~/ and named catkin_ws:

source /opt/ros/kinetic/setup.bash

cd ~/catkin_ws/src && git clone https://github.com/ros-perception/image_pipeline

cd ~/catkin_ws && catkin_make --only-pkg-with-deps image_view

Now you should be able to find the package:

source ~/catkin_ws/devel/setup.bash

rospack find image_view

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-03-15 11:54:13 -0500

Seen: 2,265 times

Last updated: May 22