Ask Your Question
0

moveit cant find GLEW -Solved. sources.list problem

asked 2017-02-15 16:07:50 -0500

w gravatar image

updated 2017-02-16 10:02:49 -0500

Original Rosdep was done on the wrong directory by me.....sorry. This made it seem like it was a install issue, when it was not. Many thanks to gvdhoorn who continues to attempt to sove these issues that are mostly due to my own inexperience.

Still working through the process. SOLVED.

Attempting a build from source on a debian jessie installation, have rosdep all issues, yet it fails to build with an .....

CMake Error at /usr/share/cmake-3.0/Modules/FindPackageHandleStandardArgs.cmake:343 {_FPHSA_FAILURE_MESSAGE}
Could not find GLEW (missing: GLEW_INCLUDE_DIR GLEW_LIBRARY)

Is this an env variable that should be set? ANY pointers would be helpful , thank you.

As the ever present and helpful (gvdhoorn) requested Here is the additional data :) :

Below is where I Rosdep'd the src dir:

user1@hpdeb:~/ros_catkin_ws/src$ rosdep install --from-paths . --ignore-src --rosdistro indigo
executing command [sudo -H apt-get install freeglut3-dev]
[sudo] password for user1: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package freeglut3-dev
ERROR: the following rosdeps failed to install
  apt: command [sudo -H apt-get install freeglut3-dev] failed
user1@hpdeb:~/ros_catkin_ws/src$

Here is the command I used to build the source:

user1@hpdeb:~/ros_catkin_ws$ catkin_make install --extend /opt/ros/indigo --cmake-args -DCMAKE_BUILD_TYPE=Release

Here is where it seems to fail:

-- Using these message generators: gencpp;genlisp;genpy
-- +++ processing catkin package: 'moveit_ros_perception'
-- ==> add_subdirectory(moveit/moveit_ros/perception)
-- Boost version: 1.55.0
-- Found the following Boost libraries:
--   thread
--   signals
CMake Error at /usr/share/cmake-3.0/Modules/FindPackageHandleStandardArgs.cmake:136 (message):
  Could NOT find GLEW (missing: GLEW_INCLUDE_DIR GLEW_LIBRARY)
Call Stack (most recent call first):
  /usr/share/cmake-3.0/Modules/FindPackageHandleStandardArgs.cmake:343 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.0/Modules/FindGLEW.cmake:35 (find_package_handle_standard_args)
  moveit/moveit_ros/perception/CMakeLists.txt:13 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/user1/ros_catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/user1/ros_catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed
user1@hpdeb:~/ros_catkin_ws$

Here was my attempt to install freeglut3:

sudo apt-get install freeglut3*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'freeglut3' for regex 'freeglut3*'
freeglut3 is already the newest version.
freeglut3 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
user1@hpdeb:~/ros_catkin_ws/src$
edit retag flag offensive close merge delete

Comments

Can you try and see whether installing libglew-dev helps? If it does, then perhaps the build_depends of one of more packages need to be updated.

gvdhoorn gravatar image gvdhoorn  ( 2017-02-16 01:45:23 -0500 )edit

Could you also please include the complete error message? What you show is just a little bit of it.

Also: which specific package is complaining (that should also be shown in the full error message)?

And: is this on x86/amd64 or ARM?

gvdhoorn gravatar image gvdhoorn  ( 2017-02-16 01:46:01 -0500 )edit

Updated question with the requested error code.

Attempted to install libglew-dev... Here is the result:

sudo apt-get install libglew-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libglew-dev
w gravatar image w  ( 2017-02-16 07:21:36 -0500 )edit

Also tried this: sudo apt-get install libglu-dev Reading package lists... Done Building dependency tree
Reading state information... Done Note, selecting 'libglu1-mesa-dev' instead of 'libglu-dev' libglu1-mesa-dev is already the newest version. 0 upgraded, 0 newly installed, 0 to

w gravatar image w  ( 2017-02-16 07:26:07 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-02-16 07:41:40 -0500

gvdhoorn gravatar image

updated 2017-02-16 07:46:21 -0500

user1@hpdeb:~/ros_catkin_ws/src$ rosdep install --from-paths . --ignore-src --rosdistro indigo
executing command [sudo -H apt-get install freeglut3-dev]
...
E: Unable to locate package freeglut3-dev
ERROR: the following rosdeps failed to install
  apt: command [sudo -H apt-get install freeglut3-dev] failed

You haven't told us whether this is an ARM platform, but in any case: according to jessie/freeglut3-dev that pkg should be available for Debian Jessie.

I'm not entirely sure whether it will solve your problem, but perhaps you can try to find out why it won't install on your platform.

Continuing with building your workspace after rosdep has failed doesn't make sense to me: the dependency is required, so I'm not surprised that it won't successfully build.

freeglut3 is already the newest version.
freeglut3 set to manually installed.

The -dev package provides the files required, so having the regular freeglut3 package installed is not enough.

edit flag offensive delete link more

Comments

This is an xeon hp proliant server older gen. Originally I rosdeb'd the wrong directory and it came up successful. Having trouble installing freeglut3-dev. Should I be modifying the apt sources file to pull it from somewhere else?

w gravatar image w  ( 2017-02-16 07:52:44 -0500 )edit

Afaict from the page I linked to it should just be available from the regular Debian repositories. A manual invocation of apt-get install freeglut3-dev also fails?

gvdhoorn gravatar image gvdhoorn  ( 2017-02-16 08:10:40 -0500 )edit

my sources.list had some issues, and I was able to apt-get freeglut3-dev. now rosdep is looking for libfcl-0.5-dev

w gravatar image w  ( 2017-02-16 09:34:02 -0500 )edit

Are you sure you are building indigo-devel?

gvdhoorn gravatar image gvdhoorn  ( 2017-02-16 10:00:12 -0500 )edit

So for my own understanding: what was the problem exactly? And how did you solve it?

gvdhoorn gravatar image gvdhoorn  ( 2017-02-16 10:06:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-02-15 16:07:50 -0500

Seen: 808 times

Last updated: Feb 16 '17