Ask Your Question
0

Having problems getting velodyne_simulator to make

asked 2017-02-11 23:25:02 -0500

H_Gottlieb gravatar image

I am trying to use the velodyne_simulator package to get a VLP-16 working in conjunction with a model of an ev. I cloned the repository a couple of weeks ago and have been working off that which has been working incredibly well.

Yesterday I was trying to make sure I could recreate my workspace so that others could have access to it and was writing a set of instructions for setup which included cloning the repository. When I tried to call catkin_make on my new test workspace I got an error message

CMake Error at /home/hugh/Desktop/alpha/devel/share/gazebo_plugins/cmake/gazebo_pluginsConfig.cmake:141 (message): Project 'velodyne_gazebo_plugins' tried to find library '-lpthread'. The
library is neither a target nor built/installed properly. Did you compile project 'gazebo_plugins'? Did you find_package() it before the subdirectory containing its code is included? Call Stack (most recent call first):
/opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:76 (find_package)
velodyne_simulator/velodyne_gazebo_plugins/CMakeLists.txt:4 (find_package)

-- Configuring incomplete, errors occurred! See also "/home/hugh/Desktop/alpha/build/CMakeFiles/CMakeOutput.log". See also "/home/hugh/Desktop/alpha/build/CMakeFiles/CMakeError.log". Makefile:7416: recipe for target 'cmake_check_build_system' failed make: * [cmake_check_build_system] Error 1 Invoking "make cmake_check_build_system" failed <

I was wondering if anybody had encountered this problem before and know a solution or can think of something that I have missed which has caused this? I am quite new to ROS and gazebo so I wouldn’t be surprised if I have missed something blindingly obvious.

When I copy over all of the folders in the src directory from my currently working workspace to the new one, catkin_make works properly but when I move just the velodyne_description folder over it still doesn’t work.

Thanks so much!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2017-02-25 18:11:13 -0500

kmhallen gravatar image

There seems to be an issue affecting several gazebo plugin ROS packages:
http://repositories.ros.org/status_pa...
http://build.ros.org/view/Kbin_uX64/j...
http://build.ros.org/view/Kbin_uX64/j...
http://build.ros.org/view/Kbin_uX64/j...

There is some discussion here:
https://github.com/ros-simulation/gaz...
https://bitbucket.org/osrf/gazebo/iss...

However, this should only be an issue if you compile gazebo_ros_pkgs from source. It shouldn't be a problem if you install with apt-get:
http://wiki.ros.org/kinetic/Installat...

edit flag offensive delete link more

Comments

Hey!

Sorry I didn't update this post. Still not really sure why there was the problem but my man, kmhallen, is completely right. If you use sudo apt-get to install the binaries then the problem was fixed.

H_Gottlieb gravatar image H_Gottlieb  ( 2017-02-25 18:39:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-02-11 23:25:02 -0500

Seen: 313 times

Last updated: Feb 25 '17