Ask Your Question
0

Eigen3 Error When Installing ROS on Raspi3 Jessie

asked 2017-02-07 00:33:00 -0500

cwmacier gravatar image

updated 2017-02-07 03:48:04 -0500

gvdhoorn gravatar image

Hello,

I keep running into this issue when trying to install ROS Kinetic on my Raspberry Pi 3. Followed a few forums with this as the problem but the CMakeLists.txt was already updated with the answers that I found and still I am running into this error. Any help would be greatly appreciated. Pretty new with ROS and coding in general so some detailed steps on how to solve this would be great!

CMake Error at CMakeLists.txt:8 (find_package):
  By not providing "FindEigen3.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Eigen3", but
  CMake did not find one.

  Could not find a package configuration file provided by "Eigen3" with any
  of the following names:

    Eigen3Config.cmake
    eigen3-config.cmake

  Add the installation prefix of "Eigen3" to CMAKE_PREFIX_PATH or set
  "Eigen3_DIR" to a directory containing one of the above files.  If "Eigen3"
  provides a separate development package or SDK, be sure it has been
  installed.


-- Configuring incomplete, errors occurred!
See also "/home/pi/ros_catkin_ws/build_isolated/eigen_stl_containers/CMakeFiles/CMakeOutput.log".
See also "/home/pi/ros_catkin_ws/build_isolated/eigen_stl_containers/CMakeFiles/CMakeError.log".
<== Failed to process package 'eigen_stl_containers': 
  Command '['/opt/ros/kinetic/env.sh', 'cmake', '/home/pi/ros_catkin_ws/src/eigen_stl_containers', '-DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/eigen_stl_containers', '-DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status 1

Reproduce this error by running:
==> cd /home/pi/ros_catkin_ws/build_isolated/eigen_stl_containers && /opt/ros/kinetic/env.sh cmake /home/pi/ros_catkin_ws/src/eigen_stl_containers -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/eigen_stl_containers -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'

Command failed, exiting.

Thank you!

edit retag flag offensive close merge delete

Comments

1

There are a few posts on this, I think I gave up with trying to fix it and went back to Indigo however here is the post with some info http://answers.ros.org/question/25072...

burf2000 gravatar image burf2000  ( 2017-02-07 08:19:33 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-02-11 16:03:41 -0500

Hi, I'm not sure if you managed to resolve your build issue but if you are willing to start over, we have a Python Fabric script that sets up ROS Kinetic (as well as OpenCV too) on a new Jessie Lite image on a Raspberry Pi 3.

Check out more info here. More than happy to answer questions is you have.

Cheers Jack

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-02-07 00:33:00 -0500

Seen: 680 times

Last updated: Feb 11 '17