ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

bash: /opt/ros/kinetic/setup.bash: No such file or directory

asked 2017-02-01 05:25:43 -0500

md.hussain gravatar image

updated 2021-10-26 09:47:31 -0500

lucasw gravatar image

when ever I open a new terminal this message appears on the top every time " bash: /opt/ros/kinetic/setup.bash: No such file or directory "

I'me working on ROS INDIGO and it's working pretty fine.. Yet I've no concern with ros kinetic so this message annoys me! Please help me if I can get rid of this..!!

Thanks :-)

edit retag flag offensive close merge delete


bash: /opt/ros/melodic/setup.bash: No such file or directory so am the beginer of ROS i am trying to install ROS but i am continuesly finding this error even though i had deleted the route line in the directory so please provide a solution

ranjii28 gravatar image ranjii28  ( 2019-05-25 10:56:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-02-01 05:35:44 -0500

gvdhoorn gravatar image

You probably have a source /opt/ros/kinetic/setup.bash line somewhere in your .bashrc (assuming you use bash as your shell).

Open $HOME/.bashrc, remove the line, save.

edit flag offensive delete link more


Thank you so much :-) Problem Solved..

md.hussain gravatar image md.hussain  ( 2017-02-01 05:49:14 -0500 )edit

I've installed ROS INDIGO and got the same error. Tried your solution too. But "HOME/.bashrc" command isn't working either. gives the following error bash: HOME/.bashrc: No such file or directory

aashrayjain gravatar image aashrayjain  ( 2017-05-17 06:41:53 -0500 )edit

It's $HOME, not HOME (note the dollar sign).

But in any case: Indigo and Kinetic don't install on the same system, so I'm curious to know what you have done exactly?

gvdhoorn gravatar image gvdhoorn  ( 2017-05-17 08:16:23 -0500 )edit

Thank you very much. Problem Solved.

Basically go to home directory then press ctrl+h then you can see hidden files then search for .bashrc and remove the lines.

mallikarjun.talagade gravatar image mallikarjun.talagade  ( 2017-07-05 01:06:26 -0500 )edit

thanks, bro. It worked.

Dinesh151 gravatar image Dinesh151  ( 2017-07-16 20:49:32 -0500 )edit

i tried the same, but its showing Permission Denied. Please help

AnirudhTopiwala gravatar image AnirudhTopiwala  ( 2017-08-29 15:04:16 -0500 )edit

@AnirudhTopiwala: your problem is most likely more a Linux problem than a ROS problem. But "permission denied" errors seem to suggest you are trying to edit another user's .bashrc. You probably don't have permission to do that.

gvdhoorn gravatar image gvdhoorn  ( 2017-08-30 02:56:27 -0500 )edit

Dear Users, I had a very similar problem, $HOME gave error. I found out this and it fixed the problem: execute gedit ~/.bashrc. On bottom in file, there is source /opt/ros/kinetic/setup.bash . Just delete that code and save. (note: the ROS distro might differ in your case). reopen terminal.

ercan_ros gravatar image ercan_ros  ( 2017-12-26 09:06:06 -0500 )edit

Question Tools

1 follower


Asked: 2017-02-01 05:25:43 -0500

Seen: 73,980 times

Last updated: Feb 01 '17