Noise when using Orbbec Astra

asked 2017-01-30 00:14:05 -0500

Connor gravatar image

updated 2017-01-30 00:17:41 -0500

I'm using the Orbbec Astra on my DLR (Like Turtlebot2, running Nvida Jetson Tk1 as CPU). When I run it with TURTLEBOT_3D_SENSOR="asus_xtion_pro" the 3D Depth Cloud looks good. When I run it with TURTLEBOT_3D_SENSOR="astra" I get strange noise. Obviously I can continue to run it with asus_xtion_pro, but, it loads the wrong model etc.. Why is it giving so much noise? How can this be fixed?

image description

image description

edit retag flag offensive close merge delete

Comments

I think you have to use the OpenNI2 module from Orbbec themselves. http://www.orbbec3d.net/Tools_SDK_Ope...

I've been trying to get this sensor working on a Pi (Failed thus far) but from what I've read there is a dev branch which has a filter in to solve this issue

MarkyMark2012 gravatar imageMarkyMark2012 ( 2017-01-30 03:02:40 -0500 )edit
MarkyMark2012 gravatar imageMarkyMark2012 ( 2017-01-30 03:02:53 -0500 )edit

I came across that. What I don't understand is. Why it okay when it thinks it's a Asus Xtion Pro? This robot came pre-installed with ROS and everything.. so it's possible they installed a new OpenNI2 module that fixed the issue, by using TURTLEBOT_3D_SENSOR="astra" it's pointed to the old one?

Connor gravatar imageConnor ( 2017-01-30 09:04:28 -0500 )edit