elp_stereo_camera installation error

asked 2017-01-25 05:16:13 -0500

sophie.shin gravatar image

updated 2017-01-25 09:10:24 -0500

Hello.

I am trying to install the elp_stereo_camera pkg on my raspberrypi2 + ubuntu 14.04 + ROS indigo.

The tutorials (moving turtles) was working fine.

I referred two links below.

https://github.com/joshvillbrandt/elp-stereo-camera-ros-pkg

http://wiki.ros.org/elp_stereo_camera

However, now I faced on the error which is "unable to locate package"

Regarding the guideline on the link "https://github.com/joshvillbrandt/elp-stereo-camera-ros-pkg"

I finished following step successfully.

$ sudo apt-get update

$ sudo apt-get install ros-indigo-ros-base ros-indigo-image-common ros-indigo-image-transport-plugins ros-indigo-image-
pipeline ros-indigo-usb-cam

$ git clone https://github.com/joshvillbrandt/elp-stereo-camera-ros-pkg.git  ~/catkin_ws/src/elp_stereo_camera

$ sudo cp ~/catkin_ws/src/elp_stereo_camera/debian/99-elp-stereo-camera.rules /etc/udev/rules.d/

$ sudo udevadm control --reload-rules && sudo service udev restart && sudo udevadm trigger

I input all above on the terminal and it was looks okay.

After then, I checked the link "http://wiki.ros.org/elp_stereo_camera"

And started copy and past.

$ sudo apt-get install ros-indigo-elp-stereo-camera

and the screen showed "unable to locate package ros-indigo-elp-stereo-camera"

So I just skipped

$ sudo apt-get install ros-indigo-elp-stereo-camera

and tried

roslaunch elp_stereo_camera elp_stereo_camera.launch

and it shows

ubuntu@ubuntu:~$ roslaunch elp_stereo_camera elp_stereo_camera.launch
[elp_stereo_camera.launch] is neither a launch file in package [elp_stereo_camera] nor is [elp_stereo_camera] a launch file name
The traceback for the exception was written to the log file

so I tried

ubuntu@ubuntu:~$ source /home/ubuntu/catkin_ws/devel/setup.bash
ubuntu@ubuntu:~$ roslaunch elp_stereo_camera elp_stereo_camera.launch
... logging to /home/ubuntu/.ros/log/88b0ce68-e30f-11e6-8083-0022cffa2d4b/roslaunch-ubuntu-5635.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ubuntu:56125/

SUMMARY
========

PARAMETERS
 * /elp/left/camera_frame_id: elp_left_optical_...
 * /elp/left/camera_info_url: package://elp_ste...
 * /elp/left/camera_name: elp_left
 * /elp/left/framerate: 15
 * /elp/left/image_height: 720
 * /elp/left/image_width: 1280
 * /elp/left/pixel_format: mjpeg
 * /elp/left/video_device: /dev/elp_left
 * /elp/right/camera_frame_id: elp_right_optical...
 * /elp/right/camera_info_url: package://elp_ste...
 * /elp/right/camera_name: elp_right
 * /elp/right/framerate: 15
 * /elp/right/image_height: 720
 * /elp/right/image_width: 1280
 * /elp/right/pixel_format: mjpeg
 * /elp/right/video_device: /dev/elp_right
 * /rosdistro: indigo
 * /rosversion: 1.11.20

NODES
  /elp/
    left (usb_cam/usb_cam_node)
    right (usb_cam/usb_cam_node)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[elp/left-1]: started with pid [5653]
process[elp/right-2]: started with pid [5654]
[ERROR] [1485356910.117420579]: Cannot identify '/dev/elp_left': 2, No such file or directory
[elp/left-1] process has died [pid 5653, exit code 1, cmd /opt/ros/indigo/lib/usb_cam/usb_cam_node __name:=left __log:=/home/ubuntu/.ros/log/88b0ce68-e30f-11e6-8083-0022cffa2d4b/elp-left-1.log].
log file: /home/ubuntu/.ros/log/88b0ce68-e30f-11e6-8083-0022cffa2d4b/elp-left-1*.log

Could you please help me about this.

Any comments will be appreciated.

edit retag flag offensive close merge delete

Comments

I did $ sudo apt-get update $ sudo apt-get upgrade also, I checked the main, universe, restricted and multiverse in the update & upgrade window. Please help...

sophie.shin gravatar imagesophie.shin ( 2017-01-25 05:36:26 -0500 )edit

Please help me to figure out this problem,...

sophie.shin gravatar imagesophie.shin ( 2017-01-25 16:22:58 -0500 )edit