ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Can't run rqt after removing plugin package

asked 2017-01-13 07:00:29 -0600

fonstein gravatar image

updated 2017-01-13 07:20:24 -0600

gvdhoorn gravatar image

I've been trying to make my own rqt plugin. After a lot of back and forth, I finally got it to build. The problem now is that rqt won't run. I get the message listed below. In the last line, rqt_mypkg is listed as KeyError. This is a package I had once before, but is deleted from my workspace now. I've tried cleaning and deleting my workspace, removing and reinstalling rqt, removing and reinstalling ros but nothing works. Rqt still won't run. Anyone have any idea what is wrong?

 Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui/", line 454, in restore_settings
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui/", line 469, in _restore_settings_save_obsolete
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui/", line 493, in _restore_settings_unload_obsolete_callback
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui/", line 506, in _restore_settings_load_missing
    self._load_plugin_load(instance_id, self._restore_settings_load_missing_callback)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui/", line 225, in _load_plugin_load
    plugin_descriptor = self._plugin_descriptors[instance_id.plugin_id]
KeyError: 'rqt_mypkg/My Plugin'
edit retag flag offensive close merge delete


lucasw gravatar image lucasw  ( 2018-04-02 13:08:05 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-01-13 07:24:10 -0600

gvdhoorn gravatar image

The package you removed is probably still referenced in an ini file that stores the settings for rqt (rqt tries to recreate your perspective from when you last exited the program; it can't find the plugin, hence the error).

You should be able to fix this by either removing ~/.config/, or by editing it such that the plugin is no longer referenced.

edit flag offensive delete link more



Thanks, that worked!

fonstein gravatar image fonstein  ( 2017-01-13 07:57:03 -0600 )edit

Question Tools

1 follower


Asked: 2017-01-13 07:00:29 -0600

Seen: 1,528 times

Last updated: Jan 13 '17