Ask Your Question

I cannot play a rosbag file for gmapping.

asked 2017-01-10 00:14:13 -0500

ataniguchi gravatar image

updated 2017-01-13 00:09:48 -0500


I'm installed ros-indigo in Ubuntu 14.04 (VMware). I tried "How to Build a Map Using Logged Data". But, I did not play a rosbag file (basic_localization_stage.bag) completely. Generated map was a different map from “basic_localization_stage_ground_truth.png”.

Below is commands and the error message:

$ rosparam set use_sim_time true
$ rosrun gmapping slam_gmapping scan:=base_scan

and, another tarminal;

$ rosbag play ./basic_localization_stage.bag --clock

[ INFO] [1483110424.111356815, 124.700547870]: Laser is mounted upwards.
 -maxUrange 29.99 -maxUrange 29.99 -sigma     0.05 -kernelSize 1 -lstep 0.05 -lobsGain 3 -astep 0.05
 -srr 0.1 -srt 0.2 -str 0.1 -stt 0.2
 -linearUpdate 1 -angularUpdate 0.5 -resampleThreshold 0.5
 -xmin -100 -xmax 100 -ymin -100 -ymax 100 -delta 0.05 -particles 30
[ INFO] [1483110424.158217525, 124.745581898]: Initialization complete
update frame 0
update ld=0 ad=0
Laser Pose= -19.396 -8.33452 -1.67552
m_count 0
Registering First Scan
[ WARN] [1483110424.590366037, 125.179980513]: Detected jump back in time. Clearing TF buffer.


[ WARN] [1483110457.960022078, 158.549614954]: Detected jump back in time. Clearing TF buffer.

Others information (generated map, rqt_graph, ...)

I want to solve this problem. Thanks in advance.

edit retag flag offensive close merge delete


Error messege: [ WARN] [1483110424.590366037, 125.179980513]: Detected jump back in time. Clearing TF buffer.

ataniguchi gravatar image ataniguchi  ( 2017-01-10 05:02:20 -0500 )edit

I tried same commands in Ubuntu 12.04 (hydro), but the same problem occurred. I consulted the following pages for the order of commands.

I do not know what is wrong.

ataniguchi gravatar image ataniguchi  ( 2017-01-11 05:21:18 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2017-01-13 00:26:59 -0500

ataniguchi gravatar image

I probably solved this problem myself. I think that the cause is because the bagfile is wrong.

I got a rosbag file for gmapping from this site.

However, This bagfile (basic_localization_stage.bag) might be different from the ground truth map image (basic_localization_stage_ground_truth.png).

Therefore, I got a bagfile with the same name (basic_localization_stage.bag) from others.

In this case, gmapping and rosbag worked well. I could get a generated map like a ground truth map.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2017-01-10 00:02:38 -0500

Seen: 1,706 times

Last updated: Jan 13 '17