Ask Your Question
0

HELP unable to launch roscore

asked 2017-01-09 15:55:26 -0600

sunking gravatar image

updated 2017-01-09 16:44:04 -0600

hi, I am having trouble launching roscore. I am running Ubuntu 14.04 in a virtualbox VM. This is after rebooting the machine so I have no other ROS processes running. I am able to ping sn-VirtualBox2 just fine I have previously had no problems running ros. ANy insights would be appreciated

sn:/opt/ros/indigo$ roscore
... logging to /home/sn/.ros/log/4f95944c-d6b2-11e6-8e27-0800271175be/roslaunch-sn-VirtualBox2-2858.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://sn-VirtualBox2:39912/
ros_comm version 1.11.20


SUMMARY
========

PARAMETERS
 * /rosdistro: indigo
 * /rosversion: 1.11.20

NODES

roscore cannot run as another roscore/master is already running. 
Please kill other roscore/master processes before relaunching.
The ROS_MASTER_URI is http://sn-VirtualBox2:11311/
The traceback for the exception was written to the log file
sn:/opt/ros/indigo$

Here is the log file:

[roslaunch][INFO] 2017-01-09 12:50:18,186: Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
[roslaunch][INFO] 2017-01-09 12:50:18,190: Done checking log file disk usage. Usage is <1GB.
[roslaunch][INFO] 2017-01-09 12:50:18,190: roslaunch starting with args ['roscore', '--core']
[roslaunch][INFO] 2017-01-09 12:50:18,190: roslaunch env is {'MANDATORY_PATH': '/usr/share/gconf/
/ubuntu.mandatory.path', 'ROS_DISTRO': 'indigo', 'ROS_LOG_FILENAME': '/home/sn/.ros/log/3a8f14ce-d6ad-11e6-872a-0800271175be/roslaunch-sn-VirtualBox2-2777.log', 'XDG_GREETER_DATA_DIR': '/var/lib/lightdm-data/sn', 'GNOME_DESKTOP_SESSION_ID': 'this-is-deprecated', 'GTK_IM_MODULE': 'ibus', 'LESSOPEN': '| /usr/bin/lesspipe %s', 'PKG_CONFIG_PATH': '/opt/ros/indigo/lib/pkgconfig', 'ROSLISP_PACKAGE_DIRECTORIES': '', 'CPATH': '/opt/ros/indigo/include', 'LOGNAME': 'sn', 'WINDOWID': '29360139', 'PATH': '/opt/ros/indigo/bin:/opt/ghc/7.8.4/bin:/opt/cabal/1.22/bin:/home/sn/Software/eclipse/cpp-neon/eclipse:/home/sn/Software/jre1.8.0_101/bin:/home/sn/.opam/4.02.1/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games', 'XDG_VTNR': '7', 'GNOME_KEYRING_CONTROL': '/run/user/1000/keyring-ApksQp', 'CMAKE_PREFIX_PATH': '/opt/ros/indigo', 'LD_LIBRARY_PATH': '/opt/ros/indigo/lib', 'LANG': 'en_US.UTF-8', 'TERM': 'xterm', 'SHELL': '/bin/bash', 'XDG_SESSION_PATH': '/org/freedesktop/DisplayManager/Session0', 'XAUTHORITY': '/home/sn/.Xauthority', 'LANGUAGE': 'en_US', 'SESSION_MANAGER': 'local/sn-VirtualBox2:@/tmp/.ICE-unix/1699,unix/sn-VirtualBox2:/tmp/.ICE-unix/1699', 'SHLVL': '1', 'HACMS': '/home/sn/Projects/HACMS', 'QT_QPA_PLATFORMTHEME': 'appmenu-qt5', 'JOB': 'dbus', 'TEXTDOMAINDIR': '/usr/share/locale/', 'TEXTDOMAIN': 'im-config', 'QT4_IM_MODULE': 'xim', 'CLUTTER_IM_MODULE': 'xim', 'SESSION': 'ubuntu', 'MANPATH': ':/home/sn/.opam/4.02.1/man', 'SESSIONTYPE': 'gnome-session', 'XMODIFIERS': '@im=ibus', 'ROS_ETC_DIR': '/opt/ros/indigo/etc/ros', 'GPG_AGENT_INFO': '/run/user/1000/keyring-ApksQp/gpg:0:1', 'HOME': '/home/sn', 'SELINUX_INIT': 'YES', 'COMPIZ_BIN_PATH': '/usr/bin/', 'CAML_LD_LIBRARY_PATH': '/home/sn/.opam/4.02.1/lib/stublibs', 'XDG_RUNTIME_DIR': '/run/user/1000', 'INSTANCE': '', 'PYTHONPATH': '/opt/ros/indigo/lib/python2.7/dist-packages', 'COMPIZ_CONFIG_PROFILE': 'ubuntu', 'SSH_AUTH_SOCK': '/run/user/1000/keyring-ApksQp/ssh', 'VTE_VERSION': '3409', 'ROS_ROOT': '/opt/ros/indigo/share/ros', 'GDMSESSION': 'ubuntu', 'IM_CONFIG_PHASE': '1', 'OCAML_TOPLEVEL_PATH': '/home/sn/.opam/4.02.1/lib/toplevel', 'LESSCLOSE': '/usr/bin/lesspipe %s %s', 'GNOME_KEYRING_PID': '', 'XDG_SEAT_PATH': '/org/freedesktop/DisplayManager/Seat0', 'ROS_PACKAGE_PATH': '/opt/ros/indigo/share:/opt/ros/indigo/stacks', 'XDG_CURRENT_DESKTOP': 'Unity', 'XDG_SESSION_ID': 'c1', 'DBUS_SESSION_BUS_ADDRESS': 'unix:abstract=/tmp/dbus-owPEPrnTQZ', '_': '/opt ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-01-09 17:02:02 -0600

ahendrix gravatar image

It seems like something else is listening on port 11311. You may want to double-check that another roscore isn't running (search running process for "ros": ps aux | grep -i ros), and you can also look at which process have open ports with netstat -tlnp

edit flag offensive delete link more

Comments

OK thanks I was just doing that - I found that I had apache2 running and when i killed that it was fine

sunking gravatar imagesunking ( 2017-01-09 17:07:29 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-01-09 15:55:26 -0600

Seen: 684 times

Last updated: Jan 09 '17