How to set PointGrey framerate?

asked 2017-01-09 02:54:11 -0600

abramsbrian gravatar image

updated 2017-01-10 04:14:55 -0600

gvdhoorn gravatar image

I have a Point Grey Flea3 camera using pointgrey_camera_driver. Every time I launch it in ROS the frame rate is 7 FPS. I am able to change the frame rate to 30 FPS using rqt_reconfigure. I would like for the camera to start at 30 FPS by default. I have tried adding it as a param to the launch file but that didn't work. I also tried adding it to PointGrey.cfg but that didn't work either. I also tried adding it in the command line using "frame_rate:=30" but that didn't work.

Camera.launch

   <!-- Determine this using rosrun pointgrey_camera_driver list_cameras.
       If not specified, defaults to first camera found. -->
  <arg name="camera_serial" default="0" />
  <arg name="calibrated" default="0" />

  <group ns="camera">
    <node pkg="nodelet" type="nodelet" name="camera_nodelet_manager" args="manager" />

    <node pkg="nodelet" type="nodelet" name="camera_nodelet"
          args="load pointgrey_camera_driver/PointGreyCameraNodelet camera_nodelet_manager" >
      <param name="frame_id" value="camera" />
      <param name="serial" value="$(arg camera_serial)" />

      <!-- When unspecified, the driver will use the default framerate as given by the
           camera itself. Use this parameter to override that value for cameras capable of
           other framerates. -->
      <param name="frame_rate" value="30" />

      <!-- Use the camera_calibration package to create this file -->
      <param name="camera_info_url" if="$(arg calibrated)"
             value="file://$(env HOME)/.ros/camera_info/$(arg camera_serial).yaml" />
    </node>

    <node pkg="nodelet" type="nodelet" name="image_proc_debayer"
          args="load image_proc/debayer camera_nodelet_manager">
    </node>
  </group>
</launch>

PointGrey.cfg

gen.add("frame_rate",         double_t, SensorLevels.RECONFIGURE_RUNNING,    "Camera speed (frames per second).",                                            30, 0, 100)
edit retag flag offensive close merge delete

Comments

To my mind that should work. When I tried to increase the framerate I also modified the camera.launch file. The "frame_rate"-param was commented first so I uncommented it. I took a value of 150 (want the max). When I relaunched the camera.launch it worked with approx. 91 fps (says rqt_reconfig).

tloco gravatar imagetloco ( 2017-01-27 08:00:47 -0600 )edit

Did you solve that, pease?

ROSkinect gravatar imageROSkinect ( 2017-10-25 03:29:33 -0600 )edit