ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

How to remap serial port for RPLidar

asked 2017-01-08 05:59:06 -0600

Rayner gravatar image


I'm currently facing this issue of creating udev rule for the RPLidar sensor. I have viewed the instructions found on this page, but still unsure how to go about doing it.

So far, besides scoring through numerous udev articles and tutorials, what I have done is run the script, and check that the file is reflected in the /etc/udev/rules.d folder but it did not help in any way as I still get the bind error " Error, cannot bind to the specified serial port /dev/rplidar." when I try to launch the Rplidar sensor.

Are there any step by step guide to doing this particular RPLidar remap and giving it read and write authority? Such that rplidar -> ttyUSBX (where X is a number) is displayed when I input the "ls -l /dev |grep ttyUSB" command

Thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-01-18 03:50:41 -0600

Rayner gravatar image

I realized I had to be the root user in order to make this happen.

edit flag offensive delete link more


Could you elaborate on how you solved your problem? I am facing the same issue right now.

AdrianNeoh gravatar image AdrianNeoh  ( 2020-06-30 02:09:29 -0600 )edit

Question Tools



Asked: 2017-01-08 05:59:06 -0600

Seen: 2,059 times

Last updated: Jan 18 '17