TF problem using vrep and ros

asked 2017-01-06 05:05:39 -0600

SCrusher gravatar image

Hello, I am using V-rep in order to simulate a scenario. I have a robot publishing laser scanner data and odometry to corresponding topics. I run through ros the slam_gmapping node and I visualise the resulted map in rviz.

Even though the map is produced perfectly fine, the problem is with the base_link and base_scan frames. When I add TF in rviz in order to see the frames I get the warning:

*No transform from [base_link] to frame [map] *No transform from [base_scan] to frame [map]

However I publish the transform from base_scan to base_link and base_link to odometry, so the above should work in the sense that the slam_gmapping node publishes the odometry to map. Nevertheless, when I generate my TF tree is looks well connected. I have tried using the sim_time parameter set to true, set to false, no at all, but still I cannot get anything. I also made the vrep script to publish at the /clock topic in case there was problem with the frame_stamp but nothing changed (or basically slam_gmapping node never subscribed to that, any idea how I can do that?)

If anybody could, I would really appreciate that.

edit retag flag offensive close merge delete