local planner don't follow global plan/goal when passing corners

asked 2017-01-01 13:05:21 -0500

ZOU Lu gravatar image

updated 2017-01-02 00:02:45 -0500


Please refer to this screenshot:

wrong heading when passing corner

When turning corners, the robot does not follow the path (green line) provided by the global planner. Instead, it heads directly to the local goal, e.g. the plan point nearest to the local cost map boundary. In this situation, I wanted the robot to go through the door and enters the corridor. Seems like a trivial task, but it simply can't make it!

So, the most possible problem should be in-proper pdist_scale, gdist_scale and occdist_scale settings. It looks like the robot treats gdist_scale = 1 and the other two equals 0.

However, I didn't try that crazy combination. What I did tried is settings like this:

pdist_scale = 0.6
gdist_scale = 0.01
occdist_scale = 0.01

but they makes no difference, the screenshot shown is taken right under such settings.

Are there any possible settings or problems that could cause such issue? I'm using base_local_planner/TrajectoryPlannerROS as the local planner plugin. I would be great if I can visualize the local plan in rviz, but I already set publish_frequency = 1 for the local cost map, rviz still couldn't show anything about the local plan. Don't know why either.

Many thanks for any help!

edit retag flag offensive close merge delete


Sorry for I don't have enough priority to upload image to this site directly

I've given you some karma, please attach the image to the question.

gvdhoorn gravatar image gvdhoorn  ( 2017-01-01 14:22:06 -0500 )edit

Thanks you! @gvdhoorn, image is uploaded now

ZOU Lu gravatar image ZOU Lu  ( 2017-01-01 23:57:18 -0500 )edit