Ask Your Question
0

Cannot install ROS fuerte on Ubuntu 16.04

asked 2016-12-01 23:34:26 -0500

lionel gravatar image

updated 2016-12-02 00:13:36 -0500

gvdhoorn gravatar image

I am trying to install ROS fuerte on Ubuntu 16.04. I follow the instructions and use

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu xenial main" > /etc/apt/sources.list.d/ros-latest.list' to setup source.list

When I run sudo apt-get install ros-fuerte-desktop-full, I got the message unable to locate package ros-fuerte-desktop-full.

Is that because ROS fuerte doesn't support Ubuntu 16.04 now?

What is the lastest version of Ubuntu I can use now?

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-12-02 00:17:29 -0500

gvdhoorn gravatar image

updated 2016-12-02 01:45:00 -0500

Is that because ROS fuerte doesn't support Ubuntu 16.04 now?

Exactly. Both the installation instructions as well as REP-003 - Target Platforms list the following as supported Ubuntu versions for Fuerte:

  • Ubuntu Lucid (10.04 LTS)
  • Ubuntu Oneiric (11.10)
  • Ubuntu Precise (12.04 LTS)

Xenial (16.04) is not supported.

What is the lastest version of Ubuntu I can use now?

If you need Fuerte, then 12.04 would be the latest you can use.

Note that Fuerte has long been EOL-ed already, and is not recommended for new users. Perhaps if you can tell us why you want to install Fuerte, we can see whether there is a work-around (or if it's even really necessary).

Btw, this question has been asked a few times already, see Is it possible to use Fuerte on 14.04? and ROS on Ubuntu Xenial (16.04) fi.


Edit:

I am trying to use ORB-SLAM, and it relies on ROS Fuerte, Groovy and Hydro or ROS Indigo. So which version of ROS would you suggest

None of the compatible versions listed there are available for Ubuntu Xenial. ROS Indigo runs on Ubuntu Trusty (14.04) only (Wily is also supported, but that is already EOL).

You have two options:

  1. try to build the package in a catkin workspace on a ROS Kinetic installation: ROS Kinetic is the only ROS release available for Ubuntu Xenial, but since ORB_SLAM is buildable on Indigo, it might work on Kinetic as well. A quick look at the issue tracker shows that other users have already tried (see raulmur/ORB_SLAM#119 fi).
  2. install Ubuntu Trusty (14.04) and ROS Indigo. The package is supposed to work on that release, so (besides the OS downgrade), this would seem to be the easiest.
edit flag offensive delete link more

Comments

Thanks for your reply. I am trying to use ORB-SLAM https://github.com/raulmur/ORB_SLAM , and it relies on ROS Fuerte, Groovy and Hydro or ROS Indigo. So which version of ROS would you suggest for lastest Unbuntu?

lionel gravatar image lionel  ( 2016-12-02 00:34:02 -0500 )edit

ROS Fuerte, Groovy and Hydro or ROS Indigo

Any particular reason to pick the oldest one when you have the choice of 4 releases?

gvdhoorn gravatar image gvdhoorn  ( 2016-12-02 01:38:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-12-01 23:34:26 -0500

Seen: 782 times

Last updated: Dec 02 '16