Why I get Conflicting gazebo versions ???

asked 2016-11-28 06:59:02 -0600

DT gravatar image

Hello everyone,

I just install ubuntu 16.04 and ROS-Kinetic branch .

I installed ros-kinetic-gazebo-ros-pkgs, gazebo7 and all respective dependencies at Synaptic, then I type gazebo at the terminal but nothing has appeared, nothing has happened.Then I type gzserver and the same scenario has been happened again. I tried gzclient I got the Conflicting gazebo versions message at the terminal.

Then I tried "roslaunch gazebo_ros empty_world.launch" and I got this at the terminal ,

core service [/rosout] found

process[gazebo-1]: started with pid [15758]

process[gazebo_gui-2]: started with pid [15765]

[gazebo-1] process has died [pid 15758, exit code 255, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode worlds/empty.world __name:=gazebo __log:=/home/delnia/.ros/log/ae0a1190-b53a-11e6-bf65-94dbc9b1a0c0/gazebo-1.log].

log file: /home/delnia/.ros/log/ae0a1190-b53a-11e6-bf65-94dbc9b1a0c0/gazebo-1*.log

Conflicting gazebo versions

Segmentation fault (core dumped)

[gazebo_gui-2] process has died [pid 15765, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/delnia/.ros/log/ae0a1190-b53a-11e6-bf65-94dbc9b1a0c0/gazebo_gui-2.log]. log file: /home/delnia/.ros/log/ae0a1190-b53a-11e6-bf65-94dbc9b1a0c0/gazebo_gui-2*.log

all processes on machine have died, roslaunch will exit

shutting down processing monitor...

... shutting down processing monitor complete

done

Can anyone help me with that?

edit retag flag offensive close merge delete