How to customize hectorSlam to create accurate map of a maze, which is solved by my turtlebot?

asked 2016-11-02 21:44:27 -0600

Shubhayu Das gravatar image

updated 2016-11-02 23:26:20 -0600

I want to use Hector Slam to create a map of a maze, that my turtlebot(2) will create while solving the maze. In the hectorSlam tutorial(, it is said that using the following parameter value for odom_frame, in case my bot doesn't have any roll/pitch motion(in the mapping_default.launch file) :

param name="odom_frame" value="base_frame" /

Also I have the following lines in the (~/hector_slam_launch/launch) tutorial.launch file, as mentioned in another tutorial site:

node pkg="tf" type="static_transform_publisher" name="base_frame_to_laser" args="0.0 0.0 0.0 0.0 0.0 0.0/base_frame /laser 10" /

node pkg="rviz" type="rviz" name="rviz" args="-d $(find hector_slam_launch)/rviz_cfg/mapping_demo.rviz"/

Now, when I ros launch hector slam (after running the hokuyo_node, launching turtlebot_bringup minimal.launch, and roscore) the rviz runs fine and I can seen the 2-D boundaries fine(as in the tutorial videos). However the terminal window shows a warning:

Also the location of the bot jumps around to some other coordinate at times, which is not desirable in bot that solving a maze. ( cuz I need to get the correct path that it followed to come out of the maze!!)

So my question is, 1)how do I get rid of the warning? 2)what does the added piece of code in the tutorial.launch file mean 3)how do I minimize the jumping effect? 4)would I help if I change 'odom_frame' parameter value to 'odom' instead of 'base_frame'? 5)And if so how? Because when I tried replacing the parameter value to odom_fame it gave an error, so perhaps I also have to modify the tutorial.launch file..?

I just started ROS less than 2 weeks back. SO I AM A NOOB. PLEASE ELABORATE.

edit retag flag offensive close merge delete