Ask Your Question
0

sliding-scan problem when gmaping

asked 2016-10-31 23:04:14 -0500

sonictl gravatar image

updated 2016-11-03 00:47:58 -0500

I met error when i use gmaping:

in rviz , i see the simulated position is 1/2 of the reality, when i was using gmapping + laser_scaner to build the map.

when I echo the topic /odom , it shows me the right value. is there experts tell me how to configure this?

please see the figure below:

Thank You Very Much!!

image description

I refered the gmaping wiki page and met the tf requirements. I'm using ros_indigo.

my Question is: How to configure my gmapping or other things to make the /scan can be relative static with /map? so I can build reasonable map.

edit retag flag offensive close merge delete

Comments

using arduino_ros_bridge; neato_xv11_driver; robot_setup_tf and teleop_twist_keyboard

sonictl gravatar image sonictl  ( 2016-10-31 23:05:23 -0500 )edit

What is the actual question here?

mgruhler gravatar image mgruhler  ( 2016-11-02 10:45:06 -0500 )edit

How to configure my gmapping or other things to make the /scan can be relative static with /map? so I can build reasonable map.

sonictl gravatar image sonictl  ( 2016-11-02 20:39:58 -0500 )edit

What you describe is similar to what is mentioned in this tutorial on setting up a navigation stack. It seems as if your transnational odometry is underestimated. How eactly are you checking that the /odom topic is correct? Are you comparing it with a physical measurement?

shoemakerlevy9 gravatar image shoemakerlevy9  ( 2016-11-02 20:57:33 -0500 )edit

thank shoemakerlevy9! I did check the /odom data and the real distance robot moved. less than 5% error. I correct this sliding-scan problem by using the launch file. but I met another problem.

sonictl gravatar image sonictl  ( 2016-11-03 00:45:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-11-03 00:47:30 -0500

sonictl gravatar image

updated 2016-11-03 05:33:22 -0500

it seems like that some parameters for gmapping/slam_gmaping are incorrectly configured.

I did check the /odom data and the real distance robot moved. less than 5% error.

Finally, I corrected this sliding-scan problem by using the launch file given by rbx1 . but I met another problem: http://answers.ros.org/question/24711...

The map is like drawn with light strockes. And there are many emissive lines which is not as the reality and should be get rid of.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-10-31 23:04:14 -0500

Seen: 127 times

Last updated: Nov 03 '16