Ask Your Question
0

max_vel_theta not honored by TrajectoryPlannerROS ?

asked 2016-10-08 20:33:24 -0500

elpidiovaldez gravatar image

move_base tries to turn my robot too fast, although I believe that I set limits correctly.

My questions are:

  • Am I doing something wrong ?
  • Is this a bug ?
  • What is the solution ?

My parameter file is:

TrajectoryPlannerROS:
  max_vel_x: 0.07
  min_vel_x: 0.04
  max_vel_theta: 0.4
  min_vel_theta: -0.4
  min_in_place_vel_theta: 0.2

  acc_lim_theta: 0.2
  acc_lim_x: 0.2
  acc_lim_y: 0.2

  holonomic_robot: false

I have checked by rosparam and rqt_reconfigure that the limits on theta are being set correctly.

The problem seems to be that in-place rotations always emit cmd_vel with theta of 1.0:

linear: 
  x: 0.0
  y: 0.0
  z: 0.0
angular: 
  x: 0.0
  y: 0.0
  z: 1.0
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-10 05:41:04 -0500

Humpelstilzchen gravatar image

Its probably the in-place rotations by rotate recovery. Set max_rotational_vel to change that.

edit flag offensive delete link more

Comments

Yes, that was exactly the problem. Thank you very much.

I added max_rotational_vel=0.4 to base_local_planner_params.yaml and angular.z was limited correctly. I had not seen that parameter in rqt_reconfigure and did not know it existed.

elpidiovaldez gravatar imageelpidiovaldez ( 2016-10-11 22:03:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-10-08 20:33:24 -0500

Seen: 100 times

Last updated: Oct 10 '16