Ask Your Question
0

I tried to install PR2 simulation on Indigo but i get the command like this --- E: Unable to locate package ros-indigo-pr2-desktop -- What should i do?

asked 2016-10-05 07:04:06 -0600

mr_0ptimist gravatar image

updated 2016-10-05 12:55:00 -0600

gvdhoorn gravatar image

output:

sudo apt-get install ros-indigo-pr2-desktopReading package lists... Done
Building dependency tree       
Reading state information... Done
N: Ignoring file 'ros-latest.list.' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'ros-latest.list.' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'ros-latest.list.' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Unable to locate package ros-indigo-pr2-desktop
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-10-05 12:58:00 -0600

gvdhoorn gravatar image

updated 2016-10-05 13:08:12 -0600

Edit: not sure what the current status is, but at least at the time of answering Unable to locate package ros-indigo-pr2-desktop pr2_desktop was not being released any more.

Ignoring that, your ROS install has a problem. See below.

N: Ignoring file 'ros-latest.list.' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

I don't know whether the rest of your configuration is correct, but the error message is clear: apt is ignoring your ros-latest.list. because it does not have the file extension it is expecting.

Apt only loads files (in this case at least) with the extension .list. Your file has an extra dot (.) at the end: .list..

Just remove that dot, and things should work a little better.

Suggestion:

sudo mv /etc/apt/sources.list.d/ros-latest.list. /etc/apt/sources.list.d/ros-latest.list

Then try sudo apt-get update again. After that you can try to install the package (that won't work, as the package hasn't / won't be released, but other packages should now work).

edit flag offensive delete link more

Comments

that worked just fine! thanks alot :)

mr_0ptimist gravatar imagemr_0ptimist ( 2016-10-08 09:01:11 -0600 )edit
0

answered 2016-10-05 11:12:37 -0600

patrchri gravatar image

Try this before you install:

sudo apt-get update
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-10-05 07:04:06 -0600

Seen: 407 times

Last updated: Oct 05 '16