Ask Your Question
0

How to install joy package on jade?

asked 2016-09-14 06:35:17 -0600

Zaunkönig gravatar image

updated 2016-09-22 06:21:53 -0600

Hi, I'm trying to use the joy package for an existing project which is using ros jade. (Ubuntu)

I'm following this tutorial. When I try to do sudo apt-get install ros-indigo-joy I get an error that ros-indigo-joy could not be found. Is this the wrong version, or am I doing something else wrong?

I basically don't know anything about ros, but I now have to work on this existing project, to add a new functionality. For the node that I wrote, I can compile it using cmake . and rosmake and it works fine with the rest of the project. So at first I tried to just copy the code from joy, and compile it in the same way. This compiles seemingly fine, but my node doesn't find the joy one and therefore can't receive any messages.
I assume that this is not the right way to integrate something like joy into an already existing project, right? What would be the correct way to do it - could it even work if I just apt-get installed it?

I'd really appreciate any help!

Edit: I did get it to work eventually. It wans't possible to install it via apt get. Unfortunately, the rest of this project was also not made using catkin but rosmake (and even though we are on jade - don't ask me why...), so I was hesistant to change anything about that, for fear of breaking it. So if anyone is looking for an answer to this question, below is a good explanation on how you should actually do it.

What ended up working for me was to clone the package code into my directory, and run cmake ., make, rosmake(didn't work without make in there).

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2016-09-14 08:19:02 -0600

Shay gravatar image

updated 2016-09-14 09:49:06 -0600

If you have followed the Guide: Ubuntu install of ROS Jade and configured your Ubuntu repositories. Then you can run sudo apt-get install ros-jade-joy.

It is also OK to install a ROS node from source, but I can't address the reason why your joy doesn't function well from the info you gave.

It is strong recommended to go through all the ROS beginner tutorials.


If there is no ros-jade-joy in the apt repositories, you have to install from source. So go to your catkin workspace and clone that source code, and make the code. Then check if joy has been installed.

cd ~/catkin_ws/src
git clone https://github.com/ros-drivers/joystick_drivers.git

cd ~/catkin_ws
catkin_make

rospack find joy
edit flag offensive delete link more

Comments

Thanks for your input! I've tried that, but I get the same error (package ros-jade-joy could not be found). Unfortunately, I don't know anything about the ros installation on that computer, since I didn't set it up. (I'm definitely way out of my depth here - I don't usually work with ros.)

Zaunkönig gravatar imageZaunkönig ( 2016-09-14 08:26:41 -0600 )edit

So, just follow the install guide of ROS Jade and ROS beginner tutorials.

Shay gravatar imageShay ( 2016-09-14 08:31:33 -0600 )edit

I'm not sure what you mean - do you think it's a problem with the local ros installation? Because I don't think I can change that. After looking through the installation tutorial, I tried apt-cache search ros-jade - ros-jade-joy is not among the packages it lists.

Zaunkönig gravatar imageZaunkönig ( 2016-09-14 08:55:39 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-09-14 06:35:17 -0600

Seen: 405 times

Last updated: Sep 22 '16