Ask Your Question
0

[MoveIt!] Can't plan to a pose goal

asked 2016-08-26 10:36:15 -0600

F4bich gravatar image

updated 2016-08-28 14:09:41 -0600

gvdhoorn gravatar image

Hi,

I'm using a simple 4 DoF arm and want to use MoveIt! to calculate and execute trajectories for it. I followed the setup tutorial and the Move Group Python Interface Tutorial which allow me to give the pr2 a pose goal to which he then plans a trajectory.

However, when I'm using this approach on my own model it doesn't work. I tried various Cartesian coordinates as pose goal, some that he is definitively able to reach, but I always receive:

Fail: ABORTED: No motion plan found. No execution attempted.

and

RRTConnect: Unable to sample any valid states for goal tree

I even (unsuccessfully) tried to move to the current position using:

pose_target = group.get_current_pose()
group.set_pose_target(pose_target)

The second application from the tutorial of planning to a joint-space goal is working correctly.

The planning group I use contains all 4 joints of the arm nothing else (I also tried a group containing all joints and links). I also added an end-effector in the setup, but it didn't help.

This problem is annoying me for some time already, every hint or solution is welcomed :)

edit retag flag offensive close merge delete

Comments

1

Seeing as joint space targets work, but Cartesian ones don't: what kind of IK plugin are you using? KDL? That is known to not work that well with < 6 DoF. See if 'enable position only IK' works for you. Other options: try trac_ik or IKFast.

gvdhoorn gravatar imagegvdhoorn ( 2016-08-28 14:09:12 -0600 )edit

I was using KDL. I now tested it with tracik, but it is not working any better. However, I noticed that occasionally the ik solver does find a path, but only very rarely and without any pattern.

F4bich gravatar imageF4bich ( 2016-08-29 09:49:57 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-10-11 05:30:49 -0600

F4bich gravatar image

As gvdhoorn pointed out correctly, the IK solver had problems with the < 6 DoF robot. Using trac_ik didn't help, however, adding more DoF did.

edit flag offensive delete link more

Comments

1

Planning for 4DOFs should actually be possible, but does require a working IK solver. Have you tried using IKFast, or writing your own?

gvdhoorn gravatar imagegvdhoorn ( 2016-10-11 06:18:03 -0600 )edit

Not yet, I used the 4DoF robot only for testing purposes and now moved to a more complex robot.

F4bich gravatar imageF4bich ( 2016-10-11 09:09:40 -0600 )edit
0

answered 2016-10-14 02:07:51 -0600

improve100 gravatar image

try to modify the moveit source code. 1.add position_only_ik: True in kinematics.yaml file,but it does not work in my move group interface file.so i try 2 2../moveit/moveit_kinematics/kdl_kinematics_plugin/src/kdl_kinematics_plugin.cpp private_handle.param(group_name+"/position_only_ik", position_ik, false);// change false to true.i fix the bug.it is ok.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-26 10:36:15 -0600

Seen: 1,341 times

Last updated: Oct 11 '16