rostopic echo gets no data but node does

asked 2016-08-24 03:50:21 -0600

toblech gravatar image

This is how my setup looks like

  • desktop computer
  • odroid xu4 (arm computer)

I tried running the master on both computers and I export the the ROS_IP and ROS_MASTER_URI like that:

  • oroid: export ROS_IP=odroid_IP and export ROS_MASTER_URI=http://desktop_IP:11311
  • desktop: export ROS_IP=desktop_IP and export ROS_MASTER_URI=http://desktop_IP:11311

I publish image data from the odroid and I get the data on the desktop. I process the image data on the desktop computer and publish a std_msg::Float32 (lets call the topic "duration") message with a time stamp. So good so far...

Now here's the problem:

When I try plotting the "duration" topic with rqt or try rostopic echo "duration", I don't get any data. But when I write a small python script and subscribe to the topic "duration" and print the data on the console, it works just fine...

It also works if I run everything on the desktop computer (camera attached to the desktop) and run rqt or rostopic echo.

Any help would be appreciated

Thanks!

edit retag flag offensive close merge delete

Comments

To get it out of the way: you start rostopic in an environment where ROS_IP and ROS_MASTER_URI are correctly set? Just asking because I've seen ppl set it in one terminal, then open a new one and be surprised that things "don't work" in that one.

gvdhoorn gravatar imagegvdhoorn ( 2016-08-24 07:31:23 -0600 )edit

yes. Either I have it in my .bashrc or I source it every time I open a new terminal.

toblech gravatar imagetoblech ( 2016-08-24 07:53:34 -0600 )edit