cv_bridge may conflict with opencv 3.1

asked 2016-08-02 02:39:04 -0500

Tao_ gravatar image

I installed opencv 3 on ubuntu. And when I compile the ROS project, it gives me the following warning, though it successfully compile the whole project. It seems that cv_bridge requires opencv 2.4. So is there any way to make cv_bridge work along with opencv 3.1? Thank you.

Here is the compilation output (the warning part) :

/usr/bin/ld: warning: libopencv_imgproc.so.2.4, needed by /opt/ros/indigo/lib/libcv_bridge.so, may conflict with libopencv_imgproc.so.3.1

/usr/bin/ld: warning: libopencv_core.so.2.4, needed by /opt/ros/indigo/lib/libcv_bridge.so, may conflict with libopencv_core.so.3.1

edit retag flag offensive close merge delete

Comments

Add cv-bridge package into your workspace?

tanasis gravatar imagetanasis ( 2017-09-12 14:20:51 -0500 )edit