Ask Your Question
0

rviz: how to show video from cam in "Camera" but not "Image"

asked 2016-07-29 15:26:24 -0500

KWL gravatar image

Hi,

I am new to ROS and would like to visualize some results. I connected an usb camera and run rviz. But I can only see the video if I add "Image" display type. But if I add "Camera" display type, it shows nothing. How can I let it show in "Camera"?

Thanks !

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-07-29 16:21:18 -0500

William gravatar image

The image displays just an image. The camera display will display the image with renderings of other data in the scene rendered on top of it, but in order to do that it requires /tf data that creates a tree between the "fixed frame" (set from the "global options" group in the "Displays" panel) and the frame that the image is in (this is determined by the value of the "header->frame_id" that is published within each image message).

So probably you don't have /tf data to show the image in the camera display. You can work around this by setting the fixed frame to be the same thing as the image's frame id.

edit flag offensive delete link more

Comments

Thanks for your answer! I will try to work around this!

KWL gravatar image KWL  ( 2016-08-02 13:17:00 -0500 )edit

This workaround worked for me, but when I add "Robot Model", it has an error unless I change the fixed frame to base_footprint, which breaks the camera image. How do I create /tf data for the camera ?

lotharchris gravatar image lotharchris  ( 2020-01-11 08:23:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-29 15:26:24 -0500

Seen: 1,560 times

Last updated: Jul 29 '16