Ask Your Question
0

do_docker.sh from Android NDK tutorial errors out

asked 2016-07-27 16:07:20 -0600

cjr2401 gravatar image

Following the Android NDK tutorial at here, when running the do_docker.sh command, the build errors out, it does pull down the docker images, and build a few packages, but when it gets to urdfdom, it starts erroring out, not finding members of classes and namespaces. The first error it gives is:

In file included from /opt/roscpp_output/target/include/urdf_model/twist.h:44:0,
                 from /opt/roscpp_output/libs/urdfdom/urdf_parser/src/twist.cpp:38:
/opt/roscpp_output/target/include/urdf_model/pose.h: In member function 'void urdf::Vector3::init(const string&)':
/opt/roscpp_output/target/include/urdf_model/pose.h:78:25: error: 'stod' is not a member of 'std'

I'm sure this is a missing include somewhere, but since this is part of the docker image I really didn't know where to look, tried retrying a few times in case this was a linking issue, and no change. This is running it on a Ubuntu 14.04 64 bit machine.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-29 15:21:48 -0600

cjr2401 gravatar image

Issue was solved by Gary Servin of ekumen_labs, after pull request https://github.com/ekumenlabs/roscpp_... was merged the build no longer errors out.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-07-27 16:07:20 -0600

Seen: 91 times

Last updated: Jul 29 '16