ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

catkin_make error in indigo

asked 2016-07-26 08:23:49 -0500

Sed gravatar image

Hello everyone,

i've just started using ROS. i am trying to build a package and i keep getting the following error:

Traceback (most recent call last):
File "/opt/ros/indigo/share/catkin/cmake/", line 37, in <module>
File "/opt/ros/indigo/share/catkin/cmake/", line 32, in main
with open(args.outfile, 'w') as fh:
IOError: [Errno 13] Permission denied: '/home/ssc044/catkin_ws/build/ati_nano17_ros/catkin_generated    /ordered_paths.cmake'
CMake Error at /opt/ros/indigo/share/catkin/cmake/safe_execute_process.cmake:11 (message):

"/usr/bin/python" "/opt/ros/indigo/share/catkin/cmake/"
"--paths-to-order" "/opt/ros/indigo/include" "/usr/include"
"/home/ssc044/catkin_ws/devel/include" "--prefixes"
"/home/ssc044/catkin_ws/devel" "/home/ssc044/catkin_ws/src"
"/home/ssc044/catkin_ws/devel" "/home/ssc044/catkin_ws/src"
"/home/ssc044/moveit_ws/devel" "/home/ssc044/moveit_ws/src"
"/opt/ros/indigo") returned error code 1
Call Stack (most recent call first):
/opt/ros/indigo/share/catkin/cmake/list_insert_in_workspace_order.cmake:29 (safe_execute_process)
/opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:99 (list_insert_in_workspace_order)
ati_nano17_ros/CMakeLists.txt:7 (find_package)

-- Configuring incomplete, errors occurred!
See also "/home/ssc044/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/ssc044/catkin_ws/build/CMakeFiles/CMakeError.log".
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed

I've tried different solutions from the internet but nothing worked.

Thank you in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-07-26 12:56:39 -0500

William gravatar image

It looks like a permission error in the build folder, check to make sure you have the right permissions in that folder.

edit flag offensive delete link more


Thank you for you response, i accessed the folder using a password, but now i have another error:

Linking CXX shared library /home/ssc044/catkin_ws/devel/lib/ [ 35%] Built target sr_ronex_transmissions make: * [all] Error 2 Invoking "make -j4 -l4" failed

Sed gravatar image Sed  ( 2016-07-29 04:12:35 -0500 )edit

i read somewhere that emptying the build folder then cmake again would do the trick. is it the right path to follow?

Thank you again

Sed gravatar image Sed  ( 2016-07-29 04:13:44 -0500 )edit

Question Tools

1 follower


Asked: 2016-07-26 08:23:49 -0500

Seen: 974 times

Last updated: Jul 26 '16