Ask Your Question
0

Installing ROS Kinetic on Ubuntu 16.04: apt-get update fail

asked 2016-07-13 22:31:32 -0500

neuronet gravatar image

updated 2016-07-14 02:38:59 -0500

gvdhoorn gravatar image

I am following the instructions here to install ROS Kinetic: http://wiki.ros.org/kinetic/Installat...

I have configured my repositories, set up my sources.list, and set up the keys. As instructed at the site, I entered:

sudo apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key 0xB01FA116

And it said that the public key "Ros BUilder" was imported. The problem is when I then enter sudo apt-get update, I get the following:

Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [95.7 kB]                         
Get:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [94.5 kB]                                                       
Hit:4 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                              
Get:5 http://packages.ros/org/ros/ubuntu xenial InRelease                                                  
Err:5 http://packages.ros/org/ros/ubuntu xenial InRelease                            
  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
Get:6 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [260 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [256 kB]          
Get:8 http://us.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [104 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [172 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [169 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [82.3 kB]
Fetched 1,233 kB in 1s (1,197 kB/s)                               
Reading package lists... Done
E: Failed to fetch http://packages.ros/org/ros/ubuntu/dists/xenial/InRelease
  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
E: Some index files failed to download. They have been ignored, or old ones used instead.

I searched here and found a hit but it seems subtly different: http://answers.ros.org/question/22399...

I'm relatively new to Linux, and completely new to ROS, so I may be wrong in my estimation of what is different from what. But then when I just went ahead and tried to install anyway, with

sudo apt-get install ros-kinetic-desktop-full

I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-kinetic-desktop-full

This seems to have come up previously: http://answers.ros.org/question/23259...

I frankly don't fully understand the answer, and as I am not much of a Linux person I'm a little wary of going to install from source unless it is clear that is the right thing to do, so I thought I'd ask about it in a way that hopefully isn't an exact duplicate.

edit retag flag offensive close merge delete

Comments

1

If the repo index files cannot be downloaded, the error you get is to be expected (as apt-get won't know about the package).

It could be that something happened during the sync between the shadow repo and the public one, which corrupted one of the index files. Maybe @tfoote knows something.

gvdhoorn gravatar imagegvdhoorn ( 2016-07-14 02:37:23 -0500 )edit
1

And just to make sure: are you behind a proxy or a corporate firewall that may be interfering? Searching for that exact error message leads to a lot of people with similar problems, most of them mentioning proxies, firewalls, mobile broadband connections, etc.

gvdhoorn gravatar imagegvdhoorn ( 2016-07-14 02:39:24 -0500 )edit
1
gvdhoorn gravatar imagegvdhoorn ( 2016-07-14 02:45:42 -0500 )edit

How can I find out if there is a firewall/proxy interfering? I can browse internet fine--have had no probs downloading anything (it's brand new computer I just built so have had to download/install a bunch of packages). At home on Time Warner Cable, can't really move it anywhere.

neuronet gravatar imageneuronet ( 2016-07-14 07:27:16 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-07-14 07:48:52 -0500

gvdhoorn gravatar image

updated 2016-07-14 07:52:39 -0500

This has (probably) nothing to with proxies or firewalls.

From your apt-get update output:

Get:5 http://packages.ros/org/ros/ubuntu xenial InRelease

Notice that it says packages.ros/org.

That is incorrect. It should be packages.ros.org (.org, as in the TLD).

If you fix that in /etc/apt/sources.list.d/ros-latest.list, I think things will start to work.

You can use sudo nano -w /etc/apt/sources.list.d/ros-latest.list to edit the file. Use ctrl+x to save and exit (answer Y, then press enter).

Don't forget to re-run sudo apt-get update afterwards.

edit flag offensive delete link more

Comments

Strangely, when I open that file today, it is:

deb http://packages.ros.org/ros/ubuntu xenial main

And now the rest of the install yields no errors! Not sure what happened overnight, but won't complain. I will accept your answer because I think you found the problem.

neuronet gravatar imageneuronet ( 2016-07-14 08:08:10 -0500 )edit

Ok. That is strange indeed. But glad you got it working.

gvdhoorn gravatar imagegvdhoorn ( 2016-07-14 09:10:53 -0500 )edit

Yes, it doesn't make sense, as I didn't download anything in the meantime that I recall.

neuronet gravatar imageneuronet ( 2016-07-14 09:59:04 -0500 )edit

So, were you able to install ROS? I'm trying to do the same! Trying to install ROS [any version] on my ODROID C2 running Ubuntu 16.04 Xenial. If yes, please help me on what steps you followed. I ended up on the conclusion that QT5 is causing problems while installing the dependencies with rosdep.

audia8.sid gravatar imageaudia8.sid ( 2016-07-25 05:36:27 -0500 )edit

audia8.sid I got it installed following the directions here: http://wiki.ros.org/ROS/Installation

If you have problems, and they are not identical to mine, I would simply start a new question here. People would probably be able to help you.

neuronet gravatar imageneuronet ( 2016-07-25 09:01:04 -0500 )edit

thanks for the reply. But I already tried that procedure. I wanted to ask you a few things if it worked for you. which Ubuntu version are you using? Did you do it on Odroid c2? which ROS distro did you install and which installation, Ubuntu or Debian? direct or source installation? thanks

audia8.sid gravatar imageaudia8.sid ( 2016-07-25 09:20:43 -0500 )edit

On intel i7 architecture. not sure if odroid c2 is supported. For other Q's you asked, just see my original Q where that was all specified mostly in the title. :) I rec'd you start a new Q and give specifics about what is going wrong, just like I did here.

neuronet gravatar imageneuronet ( 2016-07-25 09:42:22 -0500 )edit

For those interested, audia8 has posted his/her question here: http://answers.ros.org/question/24032...

neuronet gravatar imageneuronet ( 2016-07-25 11:50:40 -0500 )edit
0

answered 2017-12-01 07:52:30 -0500

Hi, guys, I've solved the same problem by adding deb http://cz.archive.ubuntu.com/ubuntu xenial main universe to the file/etc/apt/sources.list, and run the command sudo apt-get update, then install the kinetic by run sudo apt-get install ros-kinetic-desktop-full , everything went smoothly. You guys can visit the link https://packages.ubuntu.com/xenial/al.. . for more detail. The problem is the lack of python-qt-binding in the system or something goes with the packages.

edit flag offensive delete link more

Comments

The link you posted got shortened: https://packages.ubuntu.com/xenial/al. . Can you please post a valid link? Tks

JeffBlumenthal gravatar imageJeffBlumenthal ( 2018-03-01 08:14:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-13 22:27:09 -0500

Seen: 17,460 times

Last updated: Jul 14 '16