Ask Your Question
1

OpenNI camera calibration yaml file not found

asked 2016-07-04 07:29:32 -0600

fleishman gravatar image

updated 2016-07-04 09:36:54 -0600

gvdhoorn gravatar image

This is my first question, so forgive me for any formatting issues. I'm trying to use the visp_calibration package to calibrate an Xtion pro live camera. This uses the camera1394 package, which is giving me errors.

When I run

roslaunch openni_launch openni.launch

followed by

roslaunch calib-live-firewire.launch

from the tutorial, I receive a camera not found error and the warnings:

Using default parameters for IR camera calibration.
Camera calibration file /home/baxter/.ros/camera_info/depth_1205220468.yaml not found.
Using default parameters for RGB camera calibration.
Camera calibration file /home/baxter/.ros/camera_info/rgb_1205220468.yaml not found.

I checked the terminal and get these same warnings when i run

roslaunch openni_launch openni.launch

I looked at OpenNI: Camera calibration file not found and have run:

baxter@13:24:~/ros_ws/src$ ls /home/baxter/.ros/camera_info
ls: cannot access /home/baxter/.ros/camera_info: No such file or directory
baxter@13:24:~/ros_ws/src$ ls /home/baxter/.ros
latest  log  roscore-11311.pid  rosdep  rospack_cache_02456348576439424157

Should I have the yaml files? If so, how do I get them? I can launch the camera, but it needs to publish under the /camera/image_raw topic for the calibration to work, and it seems to be publishing under /camera/rgb/image_raw and /camera/ir/image_raw.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-08-09 05:34:46 -0600

fleishman gravatar image

I fixed this by following this tutorial http://wiki.ros.org/openni_launch/Tut...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-07-04 07:29:32 -0600

Seen: 4,451 times

Last updated: Aug 09 '16