clearing costmap when sensor gives max range reading

asked 2016-06-22 16:24:42 -0600

hardy gravatar image

Hi everyone, I am using Hokoyo Lidar of 5 m for obstacle avoidance and updating the local costmap and global costmap within 2.5 m.

So, Problem I am facing is that the costmap is not cleared when the obstacle at a distance less than 2.5 m moves away. The laserscan at that moment gives 5m (which is the max range reading) as the reading but still the robot doesn't clear the obstacle which was at 2m (less than 2.5m ) distance .

The laser scan parameters for global/local map update are as follows

global_costmap_params.yaml

 obstacle_layer1:
    observation_sources: laser_scan_sensor
    laser_scan_sensor: {data_type: LaserScan, sensor_frame: /laser, topic: /scan, expected_update_rate: 0.4,
      observation_persistence: 0.0, marking: true, clearing: true, max_obstacle_height: 2.0, min_obstacle_height: 0.0, inf_is_valid: true}

costmap_common_params.yaml

#Obstacle marking parameters
obstacle_range: 2.5
max_obstacle_height: 2.0
raytrace_range: 3.0

So, I want to know how to clear the old obstacles when the sensor gives max_range. If somebody can help me with this .

Thank You

edit retag flag offensive close merge delete

Comments

1
billy gravatar imagebilly ( 2016-06-22 22:56:58 -0600 )edit

and also check the link therein to a (very old) discussion about the behaviour of the laser_projector. This is actually the tool causing the "problem".

mgruhler gravatar imagemgruhler ( 2016-06-23 01:37:48 -0600 )edit

Thanks for the reply . I think it helped me understand how the laser_projector works. It solves me my problem with LIDAR

hardy gravatar imagehardy ( 2016-06-23 10:33:25 -0600 )edit