Ask Your Question
0

/imu: VN: Permission denied

asked 2016-06-13 07:20:37 -0500

MahsaP gravatar image

Hello,

I am trying to connect an imu VN-100 Rugged to ROS via this package. But, I get the following output in my terminal:

process[rosout-1]: started with pid [13597]
started core service [/rosout]
process[imu-2]: started with pid [13607]
[ INFO] [1464357306.167245353]: Sync out rate: 20
[ INFO] [1464357306.748363389]: Connected to device at /dev/ttyUSB0
[ INFO] [1464357306.765977143]: Default serial baudrate: 115200
[ INFO] [1464357306.766011559]: Set serial baudrate to 921600
[ INFO] [1464357307.776820987]: Connected to device at /dev/ttyUSB0
[ INFO] [1464357307.783369148]: New serial baudrate: 921600
[ INFO] [1464357307.788441741]: Fetching device info.
[ INFO] [1464357307.793557811]: Model number: VN-100T-CR
[ INFO] [1464357307.798613813]: Hardware revision: 7
[ INFO] [1464357307.803668418]: Serial number: 0100017300
[ INFO] [1464357307.808746557]: Firmware version: 2.0.0.0
[ INFO] [1464357307.808777854]: Set Synchronization Control Register (id:32).
[ INFO] [1464357307.837879233]: /imu: VN: Permission denied
[imu-2] process has finished cleanly

I tried to change the baud rate of /dev/ttyUSB0 to something else according to the acceptable baud rates in this link. However, I get the same result each time.

Does anyone know how I can solve this problem.

Thank you.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-10-23 17:00:10 -0500

vik748 gravatar image

link text This is what solved it for me. Now this is a setting you can change in the launch file itself.

edit flag offensive delete link more
0

answered 2016-07-04 03:27:46 -0500

MahsaP gravatar image

The reset function in the SDK of the imu did not let me open the port. The problem is solved now.

edit flag offensive delete link more

Comments

How did you solve the issue?

vik748 gravatar imagevik748 ( 2017-10-05 12:00:51 -0500 )edit

Could you tell me how you solve this problem, please? Do I need to install any SDK before I install the ROS driver?

blueflame gravatar imageblueflame ( 2017-10-23 16:56:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-13 07:20:37 -0500

Seen: 357 times

Last updated: Jul 04 '16