Ask Your Question
0

mavros missing on kinetic?

asked 2016-06-09 12:24:40 -0500

Audren Cloitre gravatar image

Hello,

I was using mavros on Indigo and cannot manage to install again on kinetic. The package does not show up in the list of ros-kinetic-* packages.

I additionally tried to install it manually, following the instructions on this page: https://github.com/mavlink/mavros/blo...

However, when replacing my distro from jade to kinetic in the following command line:

rosdep install --from-paths src --ignore-src --rosdistro jade -y

I get the following error: E: Unable to locate package ros-kinetic-control-toolbox

I could not find the package in the list of ros-kinetic-* packages and I made sure to update my system and upgrade it. Has anyone managed to install mavros on kinetic?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-06-09 12:57:14 -0500

130s gravatar image

It seems at least the packages in this page are already build and their binaries are available already on Kinetic. Have you run apt-get update?

Also, Jade and Kinetic are not meant to work on the same Ubuntu distro. See REP-0003 for the supported hosts:

edit flag offensive delete link more

Comments

Thank you 130s for your answer. I found my mistake. I tried to install two distros of ROS to access older packages but did not readjust my sources.list and keys. After setting these for kinetic, I was able to access the package without problem.

Audren Cloitre gravatar imageAudren Cloitre ( 2016-06-09 13:10:49 -0500 )edit

Glad to help, usually upvote is what shows the others that an answer was helpful ;)

130s gravatar image130s ( 2016-06-09 13:50:15 -0500 )edit

Fixed! And thanks for pointing it out.

Audren Cloitre gravatar imageAudren Cloitre ( 2016-06-10 08:06:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-06-09 12:24:40 -0500

Seen: 1,159 times

Last updated: Jun 09 '16