Ask Your Question
0

Unexplained grid_map cells using RTAB-map

asked 2016-06-05 09:44:15 -0500

Pi Robot gravatar image

I recently started using RTAB-map (Debian package) under ROS Indigo and Ubuntu 14.04. After doing a short mapping run, I bring up localization mode and view the results in RViz. For the Map display in RViz, I am subscribing to the /rtabmap/grid_map topic and there is an odd semi-circular arc of map cells displayed in the rear half of the plane behind the robot as shown below:

image description

If I rotate the robot, the arc follows the motion. If I change the Map topic to /rtabmap/proj_map, the arc goes away and the map looks normal as shown below:

image description

Any thoughts about what that white arc behind the robot is all about?

Thanks!
patrick

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-06-05 16:49:33 -0500

matlabbe gravatar image

updated 2016-06-11 23:26:10 -0500

Hi Patrick,

It seems similar to this issue: https://github.com/introlab/rtabmap_r... . This problem affects only /rtabmap/grid_map (which is created from the laser scans).

For now, set map_negative_poses_ignored parameter to true for rtabmap node:

<node pkg="rtabmap_ros" type="rtabmap" name="rtabmap">
    <param name="map_negative_poses_ignored" type="bool" value="true"/>
    (...)
</node>

EDIT In rtabmap_ros 0.11.7-1 (new version just released on Kinetic), you can set flip_scan parameter to fill unknown cells (the arc) in front of the laser rangefinder instead of behind if mounted upside down or if scan values are taken counterclockwise (you don't have to change map_negative_poses_ignored).

<node pkg="rtabmap_ros" type="rtabmap" name="rtabmap">
    <param name="flip_scan" type="bool" value="true"/>
    (...)
</node>

cheers,

Mathieu

edit flag offensive delete link more

Comments

Thanks Mathieu. Unfortunately, when I add that parameter, I stop receiving the map altogether on the /rtabmap/grid_map topic. But you're right that I have the laser scanner upside down.

Pi Robot gravatar imagePi Robot ( 2016-06-05 22:02:53 -0500 )edit

The parameter map_negative_poses_ignored is affecting the grid_map, cloud_map and proj_map topics the same way. When true, the current sensor data is not added to the map unless the map is updated (when the robot moves). Negative nodes are temporary extra stuff added to maps for convenience.

matlabbe gravatar imagematlabbe ( 2016-06-06 11:54:39 -0500 )edit

Got it--thanks!

Pi Robot gravatar imagePi Robot ( 2016-06-06 22:11:58 -0500 )edit

Thanks @matlabbe. I'm still using Indigo but will keep the new flip_scan parameter in mind for later.

Pi Robot gravatar imagePi Robot ( 2016-06-12 09:19:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-06-05 09:44:15 -0500

Seen: 409 times

Last updated: Jun 11 '16