Ask Your Question
0

ROS FUERTE install

asked 2016-05-17 14:18:58 -0500

mafr90 gravatar image

updated 2016-05-17 14:19:44 -0500

Hi everyone, I'm having troubles when I try to install ROS FUERTE in Ubuntu 14.04. I already have installed ROS INDIGO and I need to install ROS FUERTE. I follow the page's steps:

  1. Setup source.list sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu precise main" > /etc/apt/sources.list.d/ros-latest.list'

  2. Setup keys wget http://packages.ros.org/ros.key -O - | sudo apt-key add -

  3. Update

Result of the last is:

Doesn't exist available public key to ID Imposible to get : http://ppa.launchpad.net/beineri/opt-... 404 Not Found

Imposible to get: http://ppa.launchpad.net/beineri/opt-... 404 Not Found

Finally when I try:

sudo apt-get install ros-fuerte-desktop-full

The result is:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

ros-fuerte-desktop-full : Depends: ros-fuerte-nodelet-core (= 1.6.5-s1367543602~precise) but it is not going to be installed

Depends: ros-fuerte-geometry-tutorials (= 0.1.3-s1367543014~precise) but it is not going to be installed

Depends: ros-fuerte-orocos-kinematics-dynamics (= 0.2.3-s1367486085~precise) but it is not going to be installed

Depends: ros-fuerte-filters (= 1.6.0-s1367543501~precise) but it is not going to be installed

Depends: ros-fuerte-slam-gmapping (= 1.2.7-s1371543634~precise) but it is not going to be installed

Depends: ros-fuerte-simulator-gazebo (= 1.6.16-s1371459371~precise) but it is not going to be installed

Depends: ros-fuerte-visualization (= 1.8.17-s1371542460~precise) but it is not going to be installed

Depends: ros-fuerte-vision-opencv (= 1.8.8-s1367542520~precise) but it is not going to be installed

Depends: ros-fuerte-perception-pcl (= 1.2.5-s1371449986~precise) but it is not going to be installed

Depends: ros-fuerte-geometry-experimental (= 0.2.3-s1367542184~precise) but it is not going to be installed

Depends: ros-fuerte-robot-model-visualization (= 0.1.2-s1367526937~precise) but it is not going to be installed

Depends: ros-fuerte-common-tutorials (= 0.2.3-s1367556725~precise) but it is not going to be installed

Depends: ros-fuerte-image-pipeline (= 1.8.5-s1371458788~precise) but it is not going to be installed

Depends: ros-fuerte-bfl (= 0.1.0-s1367486082~precise) but it is not going to be installed

Depends: ros-fuerte-diagnostics-monitors (= 1.4.3-s1367543711~precise) but it is not going to be installed

Depends: ros-fuerte-common-rosdeps (= 1.2.0-s1367477294~precise) but it is not going to be installed

Depends: ros-fuerte-geometry-visualization (= 0.1.1-s1367555057~precise) but it is not going to be installed

Depends: ros-fuerte-image-common (= 1.8.0-s1367543911~precise) but it is not going to be installed

Depends: ros-fuerte-bond-core (= 1.6.3-s1367525391~precise) but it is not going to be installed

Depends: ros-fuerte-python-qt-binding (= 0.1.9-s1367564963~precise) but it is not going to be installed

Depends: ros-fuerte-visualization-common (= 1.8.4-s1367527510~precise) but it is not going to be installed

Depends: ros-fuerte-physics-ode (= 1.8.0-s1367477775~precise) but it is not going to be installed

Depends: ros-fuerte-driver-common (= 1.4.0-s1367556463~precise) but it is not going to be installed

Depends: ros-fuerte-executive-smach (= 1.2.1-s1367541334~precise) but it ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-05-17 14:27:13 -0500

ahendrix gravatar image

To start, ROS Fuerte is no longer supported. You should make a strong effort to use a newer version of ROS.

As described in the fuerte installation instructions, Fuerte was only supported on Ubuntu 10.04, 11.10 and 12.04. This means that the compiled binary packages for Fuerte will have dependencies that are specific to those versions of Ubuntu, and they won't work with newer Ubuntu versions.

It may be possible to build Fuerte from source on Ubuntu 14.04, but you will likely run into compatibility issues with some of the dependencies, since dependencies such as PCL have changed considerably between Ubuntu 12.04 and 14.04.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-17 14:18:58 -0500

Seen: 400 times

Last updated: May 17 '16