I am trying to learn fuerte ros and when I execute" sudo apt-get install python-rosinstall python-rosdep" ,there always has problems,please help me [closed]

asked 2015-04-23 15:35:27 -0600

sunny2015 gravatar image

dpkg: dependency problems prevent configuration of python-catkin-pkg: python-catkin-pkg depends on python:any (>= 2.7.1-0ubuntu2). dpkg: error processing python-catkin-pkg (--configure): dependency problems - leaving unconfigured No apport report written because MaxReports is reached already dpkg: dependency problems prevent configuration of python-rospkg: python-rospkg depends on python:any (>= 2.7.1-0ubuntu2). dpkg: error processing python-rospkg (--configure): dependency problems - leaving unconfigured No apport report written because MaxReports is reached already dpkg: dependency problems prevent configuration of python-rosdistro: python-rosdistro depends on python:any (>= 2.7.1-0ubuntu2). python-rosdistro depends on python-catkin-pkg; however: Package python-catkin-pkg is not configured yet. python-rosdistro depends on python-rospkg; however: Package python-rospkg is not configured yet. dpkg: error processing python-rosdistro (--configure): dependency problems - leaving unconfigured No apport report written because MaxReports is reached already dpkg: dependency problems prevent configuration of python-rosdep: python-rosdep depends on python:any (>= 2.7.1-0ubuntu2). python-rosdep depends on python-catkin-pkg; however: Package python-catkin-pkg is not configured yet. python-rosdep depends on python-rospkg (>= 1.0.34); however: Package python-rospkg is not configured yet. python-rosdep depends on python-rosdistro (>= 0.4.0); however: Package python-rosdistro is not configured yet. dpkg: error processing python-rosdep (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of python-vcstools: python-vcstools depends on python:any (>= 2.7.1-0ubuntu2). No apport report written because MaxReports is reached already dpkg: error processing python-vcstools (--configure): dependency problems - leaving unconfigured No apport report written because MaxReports is reached already dpkg: dependency problems prevent configuration of python-wstool: python-wstool depends on python:any (>= 2.7.1-0ubuntu2). python-wstool depends on python-vcstools (>= 0.1.34); however: Package python-vcstools is not configured yet. dpkg: error processing python-wstool (--configure): dependency problems - leaving unconfigured No apport report written because MaxReports is reached already dpkg: dependency problems prevent configuration of python-rosinstall: python-rosinstall depends on python:any (>= 2.7.1-0ubuntu2). python-rosinstall depends on python-vcstools (>= 0.1.30); however: Package python-vcstools is not configured yet. python-rosinstall depends on python-rosdistro (>= 0.3.0); however: Package python-rosdistro is not configured yet. python-rosinstall depends on python-catkin-pkg; however: Package python-catkin-pkg is not configured yet. python-rosinstall depends on python-wstool (>= 0.1.1); however: Package python-wstool is not configured yet. dpkg: error processing python-rosinstall (--configure): dependency problems - leaving unconfigured No apport report written because MaxReports is reached already Errors were encountered while processing: python-catkin-pkg python-rospkg python-rosdistro python-rosdep python-vcstools python-wstool python-rosinstall E: Sub-process /usr/bin/dpkg returned an error code (1)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-11-02 01:54:52.390010