pointgrey_camera_driver not publishing data to /camera/raw_image topic

asked 2016-05-16 15:49:21 -0500

carr6433 gravatar image

I'm brand new to ROS, using Jade on Ubuntu 14.04 on x86 with kernel 3.13.0. I have a pointgrey flea3 installed and I can see it listed when I run

$ rosrun pointgrey_camera_driver list_cameras

and when I run

$ rosrun pointgrey_camera_driver camera.launch camera_serial:=14386092
$ rostopic list

I get the following

/camera/camera_info
/camera/camera_nodelet/parameter_descriptions
/camera/camera_nodelet/parameter_updates
/camera/camera_nodelet_manager/bond
/camera/image
/camera/image_color
/camera/image_color/compressed
/camera/image_color/compressed/parameter_descriptions
/camera/image_color/compressed/parameter_updates
/camera/image_color/compressedDepth
/camera/image_color/compressedDepth/parameter_descriptions
/camera/image_color/compressedDepth/parameter_updates
/camera/image_color/theora
/camera/image_color/theora/parameter_descriptions
/camera/image_color/theora/parameter_updates
/camera/image_mono
/camera/image_mono/compressed
/camera/image_mono/compressed/parameter_descriptions
/camera/image_mono/compressed/parameter_updates
/camera/image_mono/compressedDepth
/camera/image_mono/compressedDepth/parameter_descriptions
/camera/image_mono/compressedDepth/parameter_updates
/camera/image_mono/theora
/camera/image_mono/theora/parameter_descriptions
/camera/image_mono/theora/parameter_updates
/camera/image_proc_debayer/parameter_descriptions
/camera/image_proc_debayer/parameter_updates
/camera/image_raw
/camera/image_raw/compressed
/camera/image_raw/compressed/parameter_descriptions
/camera/image_raw/compressed/parameter_updates
/camera/image_raw/compressedDepth
/camera/image_raw/compressedDepth/parameter_descriptions
/camera/image_raw/compressedDepth/parameter_updates
/camera/image_raw/theora
/camera/image_raw/theora/parameter_descriptions
/camera/image_raw/theora/parameter_updates
/diagnostics
/rosout
/rosout_agg

If I try to run

$ rosrun image_view image_view image:=/camera/image_raw

I get an empty window, and when I right click on the window, I get

[ WARN] [1463431322.944317447]: Couldn't save image, no data!

If I point rqt_image_view to the /camera/image_raw topic, the window is also blank. I can get video via pointgrey's flycap utility, so I know the camera is working. What am I missing?

Thanks!

edit retag flag offensive close merge delete

Comments

Did you go through the UDEV config steps?

I've only used the point grey driver to get the camera serial # and to ensure it's properly connected to the computer. I use the camera1394 node to stream the images and camera configuration.

Laughlin gravatar imageLaughlin ( 2016-05-17 11:31:10 -0500 )edit

Hi, I am facing the same issue. Can you share the solution if you got it working?

Sam6 gravatar imageSam6 ( 2017-08-24 09:54:19 -0500 )edit

Hi @Sam6, have you tried to do 'rostopic echo /camera/image_raw'? Does that give you any information?

rsmitha gravatar imagersmitha ( 2017-08-30 15:56:43 -0500 )edit

@rsmitha Hey, thanks for asking. But I got that problem resolved. I was just doing a silly mistake of giving wrong arguments to the image_view command.

Sam6 gravatar imageSam6 ( 2017-08-31 07:33:04 -0500 )edit

@Sam6 what is the correct command? could you share? Thanks

cesarhcq gravatar imagecesarhcq ( 2019-07-25 14:16:11 -0500 )edit