Ask Your Question
1

running image_view with pointgrey flea3 camera

asked 2014-07-01 08:48:08 -0600

mister_kay gravatar image

Hello,

I installed the driver for two Flea3 Pointgrey cameras whose accessibility are (successfully) verified via:

rosrun pointgrey_camera_driver list_cameras

12062824 12062828

Now "starting" one of those cameras with

roslaunch pointgrey_camera_driver camera.launch camera_serial:=12062824

I would like to display my images with

rosrun image_view image_view image:=/camera/image

but I receive the following error code:

[ERROR] [1404221648.972130708]: Client [/image_view_1404220593387350082] wants topic /camera/image to have datatype/md5sum [sensor_msgs/Image/060021388200f6f0f447d0fcd9c64743], but our version has [wfov_camera_msgs/WFOVImage/807d0db423ab5e1561cfeba09a10bc88]. Dropping connection. [ERROR] [1404221696.898906591]: Client [/image_view_1404221696410391988] wants topic /camera/image to have datatype/md5sum [sensor_msgs/Image/060021388200f6f0f447d0fcd9c64743], but our version has [wfov_camera_msgs/WFOVImage/807d0db423ab5e1561cfeba09a10bc88]. Dropping connection.

It seems like the camera.launch script publishes the images in a message format which is not known to image_view.

As I am a beginner to Linux as well as ROS I would like to ask for some tips how to publish my images (or edit camera.launch) in a certain way, eg. under the topic "left_camera/image".

Also how would I take a first step in displaying my images from the camera?

Thank you!

edit retag flag offensive close merge delete

Comments

Can I Know how did you resolve this issue ?

asdfgf gravatar imageasdfgf ( 2016-06-28 13:44:15 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-24 22:55:02 -0600

When you go to run image_view, you have to view the "raw" image format using rosrun image_view image_view image:=/camera/image_raw.

Let me know if this works and if you are able to view both at once. I'm having issues attempting to view both streams simultaneously at the moment.

edit flag offensive delete link more

Comments

Hi, when I run the above command, a blank window opens up. I am able to get some data when I run 'rostopic echo /camera/image' but not able to view it using image_view. What could it be that am doing wrong?

Sam6 gravatar imageSam6 ( 2017-08-24 10:16:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-01 08:48:08 -0600

Seen: 1,089 times

Last updated: Jul 01 '14