Ask Your Question
2

mapviz: No transform between /wgs84 to odom

asked 2016-05-12 13:48:58 -0600

fandrade gravatar image

I am running robot_localization with an IMU and a GPS. I can visualize the pose estimation it in mapviz and it looks good. Now I want to set the plug-in Tile_map (with MapQuest) but i am having this error message "No transform between /wgs84 and odom" and i am not sure what to do.

thanks in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-05-12 15:08:26 -0600

fandrade gravatar image

updated 2016-05-12 15:12:24 -0600

Ok, I "solved" it by using

rosrun swri_transform_util initialize_origin.py

I said "solved" because my tf tree looks weird (it is not a tree).

It looks like:

imu_link -> base_link
far_field -> origin
              -> far_field_identity
map -> map_identity
odom
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-12 13:48:58 -0600

Seen: 686 times

Last updated: May 12 '16