ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rosdep init - cannot download sources list from...

asked 2016-05-03 08:03:33 -0500

jannsta gravatar image

I've tried installing ros into a virtual machine on several ubuntu packages for several ros permutations that ought to be compatible. I have also downloaded the ros virtual machines from nootrix ( ) - I have tried ros Indigo, Jade and Hydro from this site.

On each occasion, when I enter 'sudo rosdep init' or 'sudo -E rosdep init' I get the 'ERROR: cannot download default sources list from: message.

There are many other forum posts about this but I have tried the suggestions I have found on these and they all seem to be to no avail.

I am using the 'NAT' network setting in VM Virtualbox and I am not using a proxy server, nor does there seem to be an https_proxy environment variable set in the environment variables.

I have tried copying the sources file to /etc/ros/rosdep/sources.list.d/ but when I do 'rosdep update' I get a similar set of error messages for each entry in sources.list.d:

"ERROR: unable to process source [ ]:

I'm sure there is something really basic that I am doing wrong but don't seem to be able to figure out what it is. Thus any debugging advice for the resolution of this issue would be greatly appreciated!

edit retag flag offensive close merge delete


Basic networking does work in the VM? Does wget work?

gvdhoorn gravatar image gvdhoorn  ( 2016-05-03 11:52:09 -0500 )edit

Yes and no... On ROS indigo (ubuntu 14.04) that command works. On ROS hydro (ubuntu 12.04 & 10.04 - the ROS version I'm trying to use) I get error message:

OpenSSL: error:140773E8:SSL routines:SSL23_GET_SERVER_HELLO:reason(1000) Unable to establish SSL connection.

jannsta gravatar image jannsta  ( 2016-05-04 04:18:17 -0500 )edit

Your Hydro VM is probably in need of some updates (various SSL libraries have seen some major updates, and the OS you list are rather old). If you Trusty VM works, can you try sudo rosdep init again? Github sometimes suffers from transient networking errors.

gvdhoorn gravatar image gvdhoorn  ( 2016-05-04 04:37:58 -0500 )edit

'Unable to establish SSL connection' seems to be consistent behaviour in Ubuntu 12.04 for rosdep init. If I use the manual file (sources.list.d) copy method to get around this step is there a manual workaround for the 'rosdep update' instruction?

jannsta gravatar image jannsta  ( 2016-05-05 10:19:30 -0500 )edit

Have you updated the ubuntu installation in the VM? There have been numerous updates to (Open)SSL, so I can imagine that the VM is out of date. I'd try that first.

gvdhoorn gravatar image gvdhoorn  ( 2016-05-05 11:08:11 -0500 )edit

Sorry, yeah I should have mentioned that I made sure all of the Ubuntu updates (for precise pangolin) are up to date. I've tried with the nootrix VM and a second VM that I have set up myself from scratch.

jannsta gravatar image jannsta  ( 2016-05-05 12:31:12 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2019-11-05 02:39:55 -0500

toby gravatar image

updated 2019-11-05 22:22:49 -0500

I have found a anwser.

Now, I place my solution here:

1.make a new directory and navigate to it, then create a new document.

$ sudo mkidr -p /etc/ros/rosdep/sources.list.d
$ cd /etc/ros/rosdep/sources.list.d
$ sudo gedit 20-default.list

2. go to the link 3. copy the contents from the link to the 20-default.list. which may like this:

# os-specific listings first
yaml osx   
# generic
gbpdistro fuerte   
# newer distributions (Groovy, Hydro, ...) must not be listed anymore, they are being fetched from the rosdistro 
index.yaml instead

4. replace the all the to in 20-default.list document, then save and close it. 5. run rosdep update

edit flag offensive delete link more



Please do not post link-only answers to external sites. The site you link is also in Chinese. ROS Answers has English as its primary language.

At the very least include a summary here in your answer.

gvdhoorn gravatar image gvdhoorn  ( 2019-11-05 03:07:37 -0500 )edit

Question Tools


Asked: 2016-05-03 08:03:33 -0500

Seen: 14,041 times

Last updated: Nov 05 '19