Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

rosdep init - cannot download sources list from...

I've tried installing ros into a virtual machine on several ubuntu packages for several ros permutations that ought to be compatible. I have also downloaded the ros virtual machines from nootrix (http://nootrix.com/software/virtualizing-ros/) - I have tried ros Indigo, Jade and Hydro from this site.

On each occasion, when I enter 'sudo rosdep init' or 'sudo -E rosdep init' I get the 'ERROR: cannot download default sources list from: https://raw.github.com/ros/rosdistro/master/rosdep/sources.list.d/20-default.list' message.

There are many other forum posts about this but I have tried the suggestions I have found on these and they all seem to be to no avail.

I am using the 'NAT' network setting in VM Virtualbox and I am not using a proxy server, nor does there seem to be an https_proxy environment variable set in the environment variables.

I have tried copying the sources file to /etc/ros/rosdep/sources.list.d/ but when I do 'rosdep update' I get a similar set of error messages for each entry in sources.list.d:

"ERROR: unable to process source [https://github.com/ros/rosdistro/raw/master/rosdep/osx-homebrew.yaml]: <urlopen error="" [errno="" 1]="" _ssl.c:504:="" error:140773e8:ssl="" routines:ssl23_g"<="" p="">

I'm sure there is something really basic that I am doing wrong but don't seem to be able to figure out what it is. Thus any debugging advice for the resolution of this issue would be greatly appreciated!