Ask Your Question
0

EX-106 no motor found

asked 2016-04-17 03:44:32 -0500

zion gravatar image

updated 2016-04-17 05:36:31 -0500

gvdhoorn gravatar image

I use a EX-106+ dynamixel motor with ubuntu 14.04 and ROS dynamixel. I connect servo to ubuntu using a usb-2-485 adapter and it worked fine on Windows7 Dynamixel Wizard. I got the servo ID=1 and baud rate=1000000. but when I use my_dynamixel_tutorials:

roslaunch my_dynamixel_tutorial controller_manager.launch

it gives me:

... logging to /home/gzy/.ros/log/fe5f2d0a-0474-11e6-ba60-b82a72edee5e/roslaunch-gzy-PC-6485.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://gzy-PC:42934/

SUMMARY
========

PARAMETERS
 * /dynamixel_manager/namespace: dxl_manager
 * /dynamixel_manager/serial_ports/pan_tilt_port/baud_rate: 1000000
 * /dynamixel_manager/serial_ports/pan_tilt_port/max_motor_id: 25
 * /dynamixel_manager/serial_ports/pan_tilt_port/min_motor_id: 1
 * /dynamixel_manager/serial_ports/pan_tilt_port/port_name: /dev/ttyUSB0
 * /dynamixel_manager/serial_ports/pan_tilt_port/update_rate: 20
 * /rosdistro: indigo
 * /rosversion: 1.11.16

NODES
  /
    dynamixel_manager (dynamixel_controllers/controller_manager.py)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[dynamixel_manager-1]: started with pid [6503]
/opt/ros/indigo/lib/python2.7/dist-packages/dynamixel_driver/dynamixel_serial_proxy.py:92: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see http://wiki.ros.org/rospy/Overview/Publishers%20and%20Subscribers for more information.
  self.motor_states_pub = rospy.Publisher('motor_states/%s' % self.port_namespace, MotorStateList)
/opt/ros/indigo/lib/python2.7/dist-packages/dynamixel_driver/dynamixel_serial_proxy.py:93: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see http://wiki.ros.org/rospy/Overview/Publishers%20and%20Subscribers for more information.
  self.diagnostics_pub = rospy.Publisher('/diagnostics', DiagnosticArray)
[INFO] [WallTime: 1460881863.930952] pan_tilt_port: Pinging motor IDs 1 through 25...
[FATAL] [WallTime: 1460881865.939556] pan_tilt_port: No motors found.
================================================================================REQUIRED process [dynamixel_manager-1] has died!
process has died [pid 6503, exit code 1, cmd /opt/ros/indigo/lib/dynamixel_controllers/controller_manager.py __name:=dynamixel_manager __log:=/home/gzy/.ros/log/fe5f2d0a-0474-11e6-ba60-b82a72edee5e/dynamixel_manager-1.log].
log file: /home/gzy/.ros/log/fe5f2d0a-0474-11e6-ba60-b82a72edee5e/dynamixel_manager-1*.log
Initiating shutdown!
================================================================================
[dynamixel_manager-1] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

and the launch/controller_manager.launch is this:

<!-- -*- mode: XML -*- -->

<launch>
    <node name="dynamixel_manager" pkg="dynamixel_controllers" type="controller_manager.py" required="true" output="screen">
        <rosparam>
            namespace: dxl_manager
            serial_ports:
                pan_tilt_port:
                    port_name: "/dev/ttyUSB0"
                    baud_rate: 1000000
                    min_motor_id: 1
                    max_motor_id: 25
                    update_rate: 20
        </rosparam>
    </node>
</launch>

same problem with dynamixel_contollers

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-17 11:55:54 -0500

rorromr gravatar image

When I have ping problems I use this standalone library for check motor IDs and baudrate, it's simple to edit and you can create your own scan scripts. Sometimes dynamixel_driver doesn't find motors, but this library do it, then I run again dynamixel_driver and works correctly. (lib_robotis.py) http://www.hizook.com/blog/2010/03/14...

Regards

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-04-17 03:44:32 -0500

Seen: 142 times

Last updated: Apr 17 '16