Ask Your Question
0

ROS / Point Grey Chameleon USB3 Cam / No Colour Images

asked 2016-04-11 06:25:58 -0500

Crusty gravatar image

updated 2016-04-11 09:30:34 -0500

Hello everyone,

I almost feel silly asking this, but I have sunken enough time into this now, and can't figure it out. I have a USB3 Pt Grey Chameleon Camera, installed according to the ROS guide. Works fine, but by default it outputs a gray valued image. (It's a colour camera). Camera is plugged via an active USB3 5m extension cable into a USB3 port. I cannot convince the camera to output a colour image. I am on ROS Indigo on 64Bit Ubuntu 14.04.1

Steps taken so far:

$ sudo apt-get install ros-indigo-pointgrey-camera-driver

$ sudo cat /etc/udev/rules.d/99-pt-grey-chameleon.rules SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device",ATTRS{idVendor}=="1e10", MODE="0666"

$ rosrun pointgrey_camera_driver list_cameras Number of cameras found: 1 [0]Serial: 15374833, Model: Chameleon3 CM3-U3-13S2C, Vendor: Point Grey Research, Sensor: Sony ICX445AL (1/3" 1296x964 CCD), Resolution: 1288x964, Color: false, Firmware Version: 1.2.3.1

Not sure why this says colour:false, it definitely is a colour camera: https://www.ptgrey.com/chameleon3-13-...

Launched rqt with image view, all works fine. Can change the params like fps successfully with rqt / dynreconfig. Changing the video mode on the camera via RQT kills the camera and/or my entire machine.

The default running mode of the camera is Format7_Mode0. I tried changing it to Format2_Mode1 ("1280x960_bayer8") hoping that I would get a bayer image to the debayer it and end up with colour. Doing so freezes the camera though, and power cycling usually doesnt help.

Any ideas would be greatly appreciated, thanks!

Edit: I use the roslaunch command as given on the ROS wiki page, and the debayer nodelet is happily running and publishing a /color topic, which isn't there when debayer is not running. The /color topic visualized in RQT is still greyscale.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-04-11 10:27:49 -0500

Crusty gravatar image

Answer to my own question:

I switched to a different ROS Point Grey stack from Kumar Robotics ( https://github.com/KumarRobotics/flea3 ) that works for me. Seems that this stack is simply too old for USB3 Pt Grey cameras.

edit flag offensive delete link more

Comments

USB3 Cameras are supposed to be supported. Perhaps you could file your issue as a bug: https://github.com/ros-drivers/pointg...

John Hoare gravatar image John Hoare  ( 2016-04-11 11:48:15 -0500 )edit

Thanks, done :)

Crusty gravatar image Crusty  ( 2016-04-12 03:50:02 -0500 )edit

I get the same problem in rviz with $ roslaunch pointgrey_camera_driver camera.launch. there are three published topics to pick: /camera/image_raw, /camera/image_mono and /camera/image_color. Choosing the last topic does not visualize any image at all whereas /camera/image_raw visualizes grayscale raw image from sensor! Did u submit an issue on their github page?

Farid gravatar image Farid  ( 2020-07-02 05:26:21 -0500 )edit
0

answered 2016-04-11 09:27:55 -0500

John Hoare gravatar image

Are you starting with roslaunch pointgrey_camera_driver camera.launch or just by using rosrun? The driver is written to get a bayer image off the camera, and then use the nodelets from image_proc to debayer and create a color image.

edit flag offensive delete link more

Comments

I am using roslaunch pointgrey_camera_driver camera.launch

Crusty gravatar image Crusty  ( 2016-04-11 09:28:37 -0500 )edit

how is this an answer? this should be comment cuz it does not solve the problem

Farid gravatar image Farid  ( 2020-07-02 05:22:01 -0500 )edit
0

answered 2016-08-19 03:41:50 -0500

sathya.bhat gravatar image

Hello there,

I too have the exact same problem. When I run "pointgrey_camera_driver list_cameras" the sensor that shows is Sony ICX445AL, which is not the one present in the chameleon 3 camera (ON Semi PYTHON 1300). Seems that this package does not support this sensor either. I have downloaded ROS Point Grey stack from Kumar Robotics, but I have not been able to make it work. The "camera_base" dependency installation to ROS include folder itself is not getting executed. Can someone guide me here?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-04-11 06:25:58 -0500

Seen: 1,568 times

Last updated: Apr 11 '16