Ask Your Question
0

image_proc warning /camera/camera/...

asked 2011-07-07 03:47:12 -0600

prp gravatar image

Hi all,

I am receiving warnings from image_proc every 30 seconds or so:

Note the doubling of 'camera'.

The prosilica_camera node is publishing /camera/image_raw and /camera/camera/info, and image_proc is subscribed to them with no problem, other than the persistent warnings. I am launching the nodes with:

<launch>
  <node name="launch_prosilica_camera" pkg="prosilica_camera" type="prosilica_node" output="screen">
    <param name="~trigger_mode" type="str" value="streaming"/>
  </node>
  <node name="launch_image_proc" pkg="image_proc" type="image_proc" output="screen">
    <env name="ROS_NAMESPACE" value="camera"/>
  </node>
</launch>

It could be me, but I think this behavior just began recently, perhaps due to an update.

Any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-07-07 05:36:09 -0600

prp gravatar image

Ah, found it. Not sure why the behavior changed recently, but the fix is to launch image_proc in the "/camera" name space, not in "camera". The modified .launch file is:

<launch>
  <node name="launch_prosilica_camera" pkg="prosilica_camera" type="prosilica_node" output="screen">
    <param name="~trigger_mode" type="str" value="streaming"/>
  </node>
  <node name="launch_image_proc" pkg="image_proc" type="image_proc" output="screen">
    <env name="ROS_NAMESPACE" value="/camera"/>
  </node>
</launch>

Thanks for the views!

edit flag offensive delete link more

Comments

It's also recommended to use the <remap> roslaunch tag instead of the ROS_NAMESPACE environment variable.
tfoote gravatar imagetfoote ( 2011-07-09 08:47:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-07 03:47:12 -0600

Seen: 202 times

Last updated: Jul 07 '11