Ask Your Question
0

rosmake doesn't create binaries

asked 2016-04-06 06:28:19 -0500

capstayn gravatar image

I'm following the ROSNodeTutorialC++ (here). I've previously installed ROS indigo on ubuntu 14.04 and done some others tutorials.

When I run cmake . in the folder node_example some suspicious warnings appear (see this ROS question, unanswered), and then when I run rosmake, following the tutorial's instructions, lots of messages about "No Makefile in package ..." are printed off (which apparently is fine, according to this answer) but the usual messages expected from a make call don't appear at all. This is the extract that deals with node_example:

[rosmake-7] Starting >>> node_example [ make ]                                  
[rosmake-7] Finished <<< node_example ROS_NOBUILD in package node_example

Consequently, no binaries are generated.

If I run though make , the compilation proceeds normally and the binaries are generated just fine.

Am I doing something wrong with rosmake? Why is it not working as expected?

P.S. By the way, the environmental path ROS_PACKAGE_PATH contains conveniently the path to the folder node _example

edit retag flag offensive close merge delete

Comments

2

is there a reason why you use rosmake and not catkin_make like in this tutorial

Mehdi. gravatar image Mehdi.  ( 2016-04-06 08:05:08 -0500 )edit

Oh, none, other than that was the instruction given in the ROSNodeTutorialC++. Just created a catking workspace and used catkin_make, and worked like a charm, thanks. So perhaps the tutorial I was following should be updated...

capstayn gravatar image capstayn  ( 2016-04-06 09:54:11 -0500 )edit

I think rosbuild is deprecated and not recommended starting from ROS Indigo. But it is true that this page misses a yellow box warning users that they should use the catkin tutorial instead.

Mehdi. gravatar image Mehdi.  ( 2016-04-06 10:32:34 -0500 )edit

Rosbuild is still supported for building from source in both Indigo and Jade. The limitation is that one cannot release rosbuild binary packages via the build farm.

joq gravatar image joq  ( 2016-04-06 13:13:12 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-06 13:15:35 -0500

joq gravatar image

It appears that you have a ROS_NOBUILD file in your node_example package.

Try removing that (presumably empty) file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-06 06:28:19 -0500

Seen: 88 times

Last updated: Apr 06 '16