Ask Your Question
0

leddar sensor connecting process always died

asked 2016-04-05 05:04:07 -0500

Zero gravatar image

I had compile the Leddar ROS package successfully, after that I running the command roslaunch leddar leddar.launch and it will show me :

... logging to /home/leddar/.ros/log/04b08b28-fb0f-11e5-8fba-c03fd56476ff/roslaunch-leddar-desktop-29633.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://leddar-desktop:36972/

SUMMARY
========

PARAMETERS
 * /leddar/fov: 45.0
 * /leddar/frame: leddar
 * /leddar/range: 50.0
 * /leddar/serial: 
 * /rosdistro: indigo
 * /rosversion: 1.11.16

NODES
  /
    leddar (leddar/leddar)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[leddar-1]: started with pid [29651]
[ INFO] [1459850056.151109908]: Connected to default
[ INFO] [1459850056.165976987]: Reconfiguring...
[ INFO] [1459850056.175064564]: Streaming...
[leddar-1] process has died [pid 29651, exit code -7, cmd /home/leddar/catkin_ws/devel/lib/leddar/leddar __name:=leddar __log:=/home/leddar/.ros/log/04b08b28-fb0f-11e5-8fba-c03fd56476ff/leddar-1.log].
log file: /home/leddar/.ros/log/04b08b28-fb0f-11e5-8fba-c03fd56476ff/leddar-1*.log
[leddar-1] restarting process
process[leddar-1]: started with pid [29697]
[ INFO] [1459850070.122849882]: Connected to default
[ INFO] [1459850070.138432672]: Reconfiguring...
[ INFO] [1459850070.145432446]: Streaming...
[leddar-1] process has died [pid 29697, exit code -7, cmd /home/leddar/catkin_ws/devel/lib/leddar/leddar __name:=leddar __log:=/home/leddar/.ros/log/04b08b28-fb0f-11e5-8fba-c03fd56476ff/leddar-1.log].
log file: /home/leddar/.ros/log/04b08b28-fb0f-11e5-8fba-c03fd56476ff/leddar-1*.log

the leddar ros package I was git clone from : https://github.com/mcgill-robotics/ro...

anyone know how to solve it? Thank you!

edit retag flag offensive close merge delete

Comments

I'm guessing, this is pretty much this question...

mgruhler gravatar image mgruhler  ( 2016-04-05 06:04:57 -0500 )edit

that problem I just simply use roslaunch leddar leddar.launch
instead of github provide one. Then the problem was solved. now is that I can connect the leddar eva kit but just a while it will died then reconnect back again, repeating the problem until totally failure

Zero gravatar image Zero  ( 2016-04-05 19:42:00 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-23 07:27:37 -0500

MARAUDER gravatar image

Hello! I had the same problem. I think that my Leddar was configured so that its measurement rate was max. Maybe too many data sent caused troubles... So, I changed 'Accumulation' and 'Oversampling' in order to decrease the measurement rate (see user guide of Leddar Evaluation Kit p28) and it fixed it. To change the configuration, I modified src/leddar/src/leddar.cpp : Search for LeddarSetProperty(Handler, PID_ACCUMULATION_EXPONENT, 0, config.accumulations); and LeddarSetProperty(Handler, PID_OVERSAMPLING_EXPONENT, 0, config.oversampling); I changed config.accumulations by 7 and config.oversampling by 3 so that measurement rate becomes 12.5 Hz. I am looking for a smarter way to configure my Leddar, but it's working for now.

edit flag offensive delete link more

Comments

ok,I will try it when I back to my school. Thank you so much.

Zero gravatar image Zero  ( 2016-05-23 19:17:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-05 05:04:07 -0500

Seen: 529 times

Last updated: May 23 '16