Ask Your Question
0

[rosrun] Couldn't find executable named mavsys

asked 2016-04-01 01:10:27 -0500

YingHua gravatar image

Hi all,

This problem appear when I update Mavros version to 1.7.

I also update the mavlink and control toobox to the last version.

And it is not be solved.

image description

and that should be like this

image description

Thanks for someone who responses >< !

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-04-01 01:20:43 -0500

mgruhler gravatar image

updated 2016-04-06 00:57:51 -0500

Seems you only have the C++ executables that get built in this project.

Did you install this from source or via apt-get?

If from source, double check if the python scripts in mavros/scripts/ are actually executable...


EDIT

@YingHua you then probably lost the file permissions due to a USB Drive which was formatted with a filesystem that does not support file permissions (e.g. NTFS or FAT, if I'm not mistaken). If you want to transfer data from one PC to another via USB, best use an EXT formatted dive to avoid this problem.

edit flag offensive delete link more

Comments

1

I just solved it ^^ all because of the permission . and thank you for response!!

sudo chmod a+x ~/catkin_ws/src/mavros/mavros/scripts/mavsys
YingHua gravatar imageYingHua ( 2016-04-01 01:25:41 -0500 )edit
1

@YingHua: please accept the answer by @mig by ticking the checkmark to the left of this answer. We don't normally close questions here on ROS Anwers, not even when they've been answered.

gvdhoorn gravatar imagegvdhoorn ( 2016-04-01 01:31:19 -0500 )edit

Also: please answer @mig's question: how did you install the mavros files? scripts/mavsys should have executable permissions already set, a git clone or installation through apt-get should not change that.

gvdhoorn gravatar imagegvdhoorn ( 2016-04-01 01:33:47 -0500 )edit

@gvdboorn :OK,Thanks for reminding me!

Dear @mig : there is some problem with my platform internet so that I download source code form github and move that to platform with usb.

YingHua gravatar imageYingHua ( 2016-04-05 20:20:12 -0500 )edit

@YingHua Thanks a lot! That solved my problem too. But, the first time I executed, I don't remember doing this. why are the permissions lost?

Karthikeya Parunandi gravatar imageKarthikeya Parunandi ( 2017-03-14 09:33:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-01 01:10:27 -0500

Seen: 201 times

Last updated: Apr 06 '16