could not resolve baxter java messages

asked 2016-03-31 08:02:37 -0500

PerceptualRobots gravatar image

I am getting a compile error when trying to use a dependency on baxter mesages. Any idea on what I am missing?

I have run this

genjava_message_artifacts --verbose -p baxter_core_msgs

so have this

./devel/share/maven/org/ros/rosjava_messages/baxter_core_msgs/1.2.0/baxter_core_msgs-1.2.0.jar

and in build.gradle have included the dependency,

dependencies { compile 'org.ros.rosjava_core:rosjava:[0.2,0.3)' compile 'org.ros.rosjava_messages:baxter_core_msgs:1.2+' }

In packages.xml I have included

<build_depend>baxter_core_msgs</build_depend>

Here's the error

Could not resolve all dependencies for configuration ':rosjava_baxter_project:compile'. Could not find any version that matches org.ros.rosjava_messages:baxter_core_msgs:1.2+. Searched in the following locations: https://github.com/rosjava/rosjava_mv... file:/home/rupert/.m2/repository/org/ros/rosjava_messages/baxter_core_msgs/maven-metadata.xml file:/home/rupert/.m2/repository/org/ros/rosjava_messages/baxter_core_msgs/ http://repository.springsource.com/ma... http://repository.springsource.com/ma... http://repository.springsource.com/ma... http://repository.springsource.com/ma... https://repo1.maven.org/maven2/org/ro... https://repo1.maven.org/maven2/org/ro... Required by: com.github.rosjava.rosjava_baxter_package:rosjava_baxter_project:0.1.0

edit retag flag offensive close merge delete